rename _end to __bss_end__Currently, _end is used for end of BSS section. We want _end to meanend of u-boot image, so we rename _end to __bss_end__ first.Signed-off-by: Po-Yu Chuang <ratbert@fa
rename _end to __bss_end__Currently, _end is used for end of BSS section. We want _end to meanend of u-boot image, so we rename _end to __bss_end__ first.Signed-off-by: Po-Yu Chuang <ratbert@faraday-tech.com>
show more ...
Switch from archive libraries to partial linkingBefore this commit, weak symbols were not overridden by non-weak symbolsfound in archive libraries when linking with recent versions ofbinutils. A
Switch from archive libraries to partial linkingBefore this commit, weak symbols were not overridden by non-weak symbolsfound in archive libraries when linking with recent versions ofbinutils. As stated in the System V ABI, "the link editor does notextract archive members to resolve undefined weak symbols".This commit changes all Makefiles to use partial linking (ld -r) insteadof creating library archives, which forces all symbols to participate inlinking, allowing non-weak symbols to override weak symbols as intended.This approach is also used by Linux, from which the gmake functioncmd_link_o_target (defined in config.mk and used in all Makefiles) isinspired.The name of each former library archive is preserved except forextensions which change from ".a" to ".o". This commit updatesreferences accordingly where needed, in particular in some linkerscripts.This commit reveals board configurations that exclude some features butinclude source files that depend these disabled features in the build,resulting in undefined symbols. Known such cases include:- disabling CMD_NET but not CMD_NFS;- enabling CONFIG_OF_LIBFDT but not CONFIG_QE.Signed-off-by: Sebastien Carlier <sebastien.carlier@gmail.com>
Rename TEXT_BASE into CONFIG_SYS_TEXT_BASEThe change is currently needed to be able to remove the boardconfiguration scripting from the top level Makefile and replace it bya simple, table driven
Rename TEXT_BASE into CONFIG_SYS_TEXT_BASEThe change is currently needed to be able to remove the boardconfiguration scripting from the top level Makefile and replace it bya simple, table driven script.Moving this configuration setting into the "CONFIG_*" name space isalso desirable because it is needed if we ever should move forward toa Kconfig driven configuration system.Signed-off-by: Wolfgang Denk <wd@denx.de>
m68k: Move cpu/$CPU to arch/m68k/cpu/$CPUSigned-off-by: Peter Tyser <ptyser@xes-inc.com>
Rename lib_generic/ to lib/Now that the other architecture-specific lib directories have beenmoved out of the top-level directory there's not much reason to have the'_generic' suffix on the commo
Rename lib_generic/ to lib/Now that the other architecture-specific lib directories have beenmoved out of the top-level directory there's not much reason to have the'_generic' suffix on the common lib directory.Signed-off-by: Peter Tyser <ptyser@xes-inc.com>
Move lib_$ARCH directories to arch/$ARCH/libAlso move lib_$ARCH/config.mk to arch/$ARCH/config.mkThis change is intended to clean up the top-level directory structureand more closely mimic Linux
Move lib_$ARCH directories to arch/$ARCH/libAlso move lib_$ARCH/config.mk to arch/$ARCH/config.mkThis change is intended to clean up the top-level directory structureand more closely mimic Linux's directory organization.Signed-off-by: Peter Tyser <ptyser@xes-inc.com>
Fix all linker script to handle all rodata sectionsA recent gcc added a new unaligned rodata section called '.rodata.str1.1',which needs to be added the the linker script. Instead of just adding
Fix all linker script to handle all rodata sectionsA recent gcc added a new unaligned rodata section called '.rodata.str1.1',which needs to be added the the linker script. Instead of just adding thisone section, we use a wildcard ".rodata*" to get all rodata linker sectiongcc has now and might add in the future.However, '*(.rodata*)' by itself will result in sub-optimal sectionordering. The sections will be sorted by object file, which causes extrapadding between the unaligned rodata.str.1.1 of one object file and thealigned rodata of the next object file. This is easy to fix by using theSORT_BY_ALIGNMENT command.This patch has not be tested one most of the boards modified. Some boardshave a linker script that looks something like this:*(.text). = ALIGN(16);*(.rodata)*(.rodata.str1.4)*(.eh_frame)I change this to:*(.text). = ALIGN(16);*(.eh_frame)*(SORT_BY_ALIGNMENT(SORT_BY_NAME(.rodata*)))This means the start of rodata will no longer be 16 bytes aligned.However, the boundary between text and rodata/eh_frame is still aligned to16 bytes, which is what I think the real purpose of the ALIGN call is.Signed-off-by: Trent Piepho <xyzzy@speakeasy.org>
ColdFire: Fix M5329EVB and M5373EVB nand issueThe Nand flash was unable to read and write properlydue to Nand Chip Select (nCE) setup was in reverseorder. Also, increase the Nand time out value t
ColdFire: Fix M5329EVB and M5373EVB nand issueThe Nand flash was unable to read and write properlydue to Nand Chip Select (nCE) setup was in reverseorder. Also, increase the Nand time out value to 60.Signed-off-by: TsiChung Liew <Tsi-Chung.Liew@freescale.com>
ColdFire: Fix M5329EVB and M5373EVB nand issueFix compilation issue caused by a few mismatches.Provide proper nand chip select enable/disable innand_hwcontrol() rather than in board_nand_init()j
ColdFire: Fix M5329EVB and M5373EVB nand issueFix compilation issue caused by a few mismatches.Provide proper nand chip select enable/disable innand_hwcontrol() rather than in board_nand_init()just enable once. Remove redundant local nand driverfunctions - nand_read_byte(), nand_write_byte() andnand_dev_ready() to use common nand driver.Signed-off-by: TsiChung Liew <Tsi-Chung.Liew@freescale.com>
ColdFire: Remove platforms mii.c fileWill use mcfmii.c driver in drivers/net rather thankeep creating new mii.c for each future platform.Remove EB+MCF-EV123, cobra5272, idmr, M5235EVB,M5271EVB,
ColdFire: Remove platforms mii.c fileWill use mcfmii.c driver in drivers/net rather thankeep creating new mii.c for each future platform.Remove EB+MCF-EV123, cobra5272, idmr, M5235EVB,M5271EVB, M5272C3, M5275EVB, M5282EVB, M5329EVB,M5373EVB, M54451EVB, M54455EVB, M547xEVB, and M548xEVB'smii.cSigned-off-by: TsiChung Liew <Tsi-Chung.Liew@freescale.com>
rename CFG_ macros to CONFIG_SYSSigned-off-by: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com>
rename environment.c in env_embedded.c to reflect is functionalitySigned-off-by: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com>
m5373evb: Update NAND driver to new API.Signed-off-by: Scott Wood <scottwood@freescale.com>
Change initdram() return type to phys_size_tThis patch changes the return type of initdram() from long int to phys_size_t.This is required for a couple of reasons: long int limits the amount of dr
Change initdram() return type to phys_size_tThis patch changes the return type of initdram() from long int to phys_size_t.This is required for a couple of reasons: long int limits the amount of dramto 2GB, and u-boot in general is moving over to phys_size_t to represent thesize of physical memory. phys_size_t is defined as an unsigned long on almostall current platforms.This patch *only* changes the return type of the initdram function (ininclude/common.h, as well as in each board's implementation of initdram). Itdoes not actually modify the code inside the function on any of the platforms;platforms which wish to support more than 2GB of DRAM will need to modifytheir initdram() function code.Build tested with MAKEALL for ppc, arm, mips, mips-el. Booted on powerpcMPC8641HPCN.Signed-off-by: Becky Bruce <becky.bruce@freescale.com>
Big white-space cleanup.This commit gets rid of a huge amount of silly white-space issues.Especially, all sequences of SPACEs followed by TAB characters getremoved (unless they appear in print st
Big white-space cleanup.This commit gets rid of a huge amount of silly white-space issues.Especially, all sequences of SPACEs followed by TAB characters getremoved (unless they appear in print statements).Also remove all embedded "vim:" and "vi:" statements which hideindentation problems.Signed-off-by: Wolfgang Denk <wd@denx.de>
Remove all the search paths from the .lds files.The cross compiler is responsible for providing the correct librariesand the logic to find the linking libraries.Signed-off-by: Jason Wessel <jaso
Remove all the search paths from the .lds files.The cross compiler is responsible for providing the correct librariesand the logic to find the linking libraries.Signed-off-by: Jason Wessel <jason.wessel@windriver.com>
ColdFire: Add M5373EVB platform support - 1Signed-off-by: TsiChungLiew <Tsi-Chung.Liew@freescale.com>Signed-off by: John Rigby <jrigby@freescale.com>
12