SPDX: Convert all of our single license tags to Linux Kernel styleWhen U-Boot started using SPDX tags we were among the early adopters andthere weren't a lot of other examples to borrow from. So
SPDX: Convert all of our single license tags to Linux Kernel styleWhen U-Boot started using SPDX tags we were among the early adopters andthere weren't a lot of other examples to borrow from. So we picked thearea of the file that usually had a full license text and replaced itwith an appropriate SPDX-License-Identifier: entry. Since then, theLinux Kernel has adopted SPDX tags and they place it as the very firstline in a file (except where shebangs are used, then it's second line)and with slightly different comment styles than us.In part due to community overlap, in part due to better tag visibilityand in part for other minor reasons, switch over to that style.This commit changes all instances where we have a single declaredlicense in the tag as both the before and after are identical in tagcontents. There's also a few places where I found we did not have a tagand have introduced one.Signed-off-by: Tom Rini <trini@konsulko.com>
show more ...
MAINTAINERS: Switch nxp.com domainfreescale.com domain is no longer reachable, so switch themaintainers' emails to nxp.com domain instead.Signed-off-by: Fabio Estevam <fabio.estevam@nxp.com>
Remove unnecessary instances of DECLARE_GLOBAL_DATA_PTRWe have a large number of places where while we historically referencedgd in the code we no longer do, as well as cases where the code added
Remove unnecessary instances of DECLARE_GLOBAL_DATA_PTRWe have a large number of places where while we historically referencedgd in the code we no longer do, as well as cases where the code addedthat line "just in case" during development and never dropped it.Signed-off-by: Tom Rini <trini@konsulko.com>
i2c: powerpc: Remove use of CONFIG_HARD_I2CDrop use of this long-deprecated option for powerpc.Signed-off-by: Simon Glass <sjg@chromium.org>
board_f: Rename initdram() to dram_init()This allows us to use the same DRAM init function on all archs. Add adummy function for arc, which does not use DRAM init here.Signed-off-by: Simon Glass
board_f: Rename initdram() to dram_init()This allows us to use the same DRAM init function on all archs. Add adummy function for arc, which does not use DRAM init here.Signed-off-by: Simon Glass <sjg@chromium.org>[trini: Dummy function on nios2]Signed-off-by: Tom Rini <trini@konsulko.com>
board_f: Drop return value from initdram()At present we cannot use this function as an init sequence call without awrapper, since it returns the RAM size. Adjust it to set the RAM size inglobal_d
board_f: Drop return value from initdram()At present we cannot use this function as an init sequence call without awrapper, since it returns the RAM size. Adjust it to set the RAM size inglobal_data instead, and return 0 on success.Signed-off-by: Simon Glass <sjg@chromium.org>Reviewed-by: Stefan Roese <sr@denx.de>
board_f: Drop board_type parameter from initdram()It looks like only cm5200 and tqm8xx use this feature, so we don't reallyneed it in generic code. Drop it and have the users access gd->board_type
board_f: Drop board_type parameter from initdram()It looks like only cm5200 and tqm8xx use this feature, so we don't reallyneed it in generic code. Drop it and have the users access gd->board_typedirectly.Signed-off-by: Simon Glass <sjg@chromium.org>Reviewed-by: Stefan Roese <sr@denx.de>
mtd: nand: Add+use mtd_to/from_nand and nand_get/set_controller_dataThese functions are part of the Linux 4.6 sync. They are being addedbefore the main sync patch in order to make it easier to ad
mtd: nand: Add+use mtd_to/from_nand and nand_get/set_controller_dataThese functions are part of the Linux 4.6 sync. They are being addedbefore the main sync patch in order to make it easier to address theissue across all NAND drivers (many/most of which do not closely tracktheir Linux counterparts) separately from other merge issues.Signed-off-by: Scott Wood <oss@buserror.net>
Use correct spelling of "U-Boot"Correct spelling of "U-Boot" shall be used in all written text(documentation, comments in source files etc.).Signed-off-by: Bin Meng <bmeng.cn@gmail.com>Reviewed
Use correct spelling of "U-Boot"Correct spelling of "U-Boot" shall be used in all written text(documentation, comments in source files etc.).Signed-off-by: Bin Meng <bmeng.cn@gmail.com>Reviewed-by: Heiko Schocher <hs@denx.de>Reviewed-by: Simon Glass <sjg@chromium.org>Reviewed-by: Minkyu Kang <mk7.kang@samsung.com>
m68k: move CONFIG_SYS_TEXT_BASE to defconfig filesFor historical reason, CONFIG_SYS_TEXT_BASE has been specifiedin various ways:[1] by board/${VENDOR}/${BOARD}/config.mk[2] by CONFIG_SYS_EXTRA
m68k: move CONFIG_SYS_TEXT_BASE to defconfig filesFor historical reason, CONFIG_SYS_TEXT_BASE has been specifiedin various ways:[1] by board/${VENDOR}/${BOARD}/config.mk[2] by CONFIG_SYS_EXTRA_OPTIONS (This was "options" field of boards.cfg before Kconfig conversion)[3] by include/configs/${BOARD}.h[4] by configs/${BOARD}_defconfigMost of M68K boards use either [1] or [2], both of which we want todeprecate. Switch them into [4], which is the newest way (Kconfig).We still allow [3] too, because it is still used by many boards andwe expect much time for conversion.Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>Acked-by: Angelo Dureghello <angelo at sysam.it>Reviewed-by: Simon Glass <sjg@chromium.org>
m68k: add architecture-specific u-boot.ldsAdd architecture-specific u-boot.lds and remove all board-specificu-boot.lds.All the .text customization that was board-specific have beenmoved inside
m68k: add architecture-specific u-boot.ldsAdd architecture-specific u-boot.lds and remove all board-specificu-boot.lds.All the .text customization that was board-specific have beenmoved inside the related include/configs, inside aLDS_BOARD_TEXT define.Signed-off-by: Angelo Dureghello <angelo@sysam.it>
kconfig: remove redundant "string" type in arch and board KconfigsNow the types of CONFIG_SYS_{ARCH, CPU, SOC, VENDOR, BOARD, CONFIG_NAME}are specified in arch/Kconfig.We can delete the ones in
kconfig: remove redundant "string" type in arch and board KconfigsNow the types of CONFIG_SYS_{ARCH, CPU, SOC, VENDOR, BOARD, CONFIG_NAME}are specified in arch/Kconfig.We can delete the ones in arch and board Kconfig files.This commit can be easily reproduced by the following command:find . -name Kconfig -a ! -path ./arch/Kconfig | xargs sed -i -e '/config[[:space:]]SYS_\(ARCH\|CPU\|SOC\|\VENDOR\|BOARD\|CONFIG_NAME\)/ { N s/\n[[:space:]]*string//}'Signed-off-by: Masahiro Yamada <yamada.m@jp.panasonic.com>
Add board MAINTAINERS filesWe have switched to Kconfig and the boards.cfg file is going tobe removed. We have to retrieve the board status and maintainersinformation from it.The MAINTAINERS for
Add board MAINTAINERS filesWe have switched to Kconfig and the boards.cfg file is going tobe removed. We have to retrieve the board status and maintainersinformation from it.The MAINTAINERS format as in Linux Kernel would be nicebecause we can crib the scripts/get_maintainer.pl script.After some discussion, we chose to put a MAINTAINERS file under eachboard directory, not the top-level one because we want to collectrelevant information for a board into a single place.TODO:Modify get_maintainer.pl to scan multiple MAINTAINERS files.Signed-off-by: Masahiro Yamada <yamada.m@jp.panasonic.com>Suggested-by: Tom Rini <trini@ti.com>Acked-by: Simon Glass <sjg@chromium.org>
kconfig: add board Kconfig and defconfig filesThis commit adds: - arch/${ARCH}/Kconfig provide a menu to select target boards - board/${VENDOR}/${BOARD}/Kconfig or board/${BOARD}/Kconfig
kconfig: add board Kconfig and defconfig filesThis commit adds: - arch/${ARCH}/Kconfig provide a menu to select target boards - board/${VENDOR}/${BOARD}/Kconfig or board/${BOARD}/Kconfig set CONFIG macros to the appropriate values for each board - configs/${TARGET_BOARD}_defconfig default setting of each board(This commit was automatically generated by a conversion scriptbased on boards.cfg)In Linux Kernel, defconfig files are located underarch/${ARCH}/configs/ directory.It works in Linux Kernel since ARCH is always given from thecommand line for cross compile.But in U-Boot, ARCH is not given from the command line.Which means we cannot know ARCH until the board configuration is done.That is why all the "*_defconfig" files should be gathered into asingle directory ./configs/.Signed-off-by: Masahiro Yamada <yamada.m@jp.panasonic.com>Acked-by: Simon Glass <sjg@chromium.org>
m68k: convert makefiles to Kbuild styleSigned-off-by: Masahiro Yamada <yamada.m@jp.panasonic.com>Cc: Jason Jin <Jason.jin@freescale.com>
Add GPL-2.0+ SPDX-License-Identifier to source filesSigned-off-by: Wolfgang Denk <wd@denx.de>[trini: Fixup common/cmd_io.c]Signed-off-by: Tom Rini <trini@ti.com>
i2c, fsl_i2c: switch to new multibus/multiadapter support- added to fsl_i2c driver new multibus/multiadpater support- adapted all config files, which uses this driverSigned-off-by: Heiko Schoche
i2c, fsl_i2c: switch to new multibus/multiadapter support- added to fsl_i2c driver new multibus/multiadpater support- adapted all config files, which uses this driverSigned-off-by: Heiko Schocher <hs@denx.de>Cc: Simon Glass <sjg@chromium.org>Cc: Stephen Warren <swarren@wwwdotorg.org>
i2c, soft-i2c: switch to new multibus/multiadapter support- added to soft_i2c driver new multibus/multiadpater support- adapted all config files, which uses this driverSigned-off-by: Heiko Schoc
i2c, soft-i2c: switch to new multibus/multiadapter support- added to soft_i2c driver new multibus/multiadpater support- adapted all config files, which uses this driverSigned-off-by: Heiko Schocher <hs@denx.de>Cc: Simon Glass <sjg@chromium.org>Cc: Stephen Warren <swarren@wwwdotorg.org>
Replace __bss_end__ with __bss_endNote this is a tree-wide change affecting multiple architectures.At present we use __bss_start, but mostly __bss_end__. This seemsinconsistent and in a number o
Replace __bss_end__ with __bss_endNote this is a tree-wide change affecting multiple architectures.At present we use __bss_start, but mostly __bss_end__. This seemsinconsistent and in a number of places __bss_end is used instead.Change to use __bss_end for the BSS end symbol throughout U-Boot. Thismakes it possible to use the asm-generic/sections.h file on allarchs.Signed-off-by: Simon Glass <sjg@chromium.org>
Refactor linker-generated arraysRefactor linker-generated array code so that symbolswhich were previously linker-generated are now compiler-generated. This causes relocation records of typeR_ARM
Refactor linker-generated arraysRefactor linker-generated array code so that symbolswhich were previously linker-generated are now compiler-generated. This causes relocation records of typeR_ARM_ABS32 to become R_ARM_RELATIVE, which makescode which uses LGA able to run before relocation aswell as after.Note: this affects more than ARM targets, as linker-lists span possibly all target architectures, notablyPowerPC.Conflicts: arch/arm/cpu/arm926ejs/mxs/u-boot-spl.lds arch/arm/cpu/arm926ejs/spear/u-boot-spl.lds arch/arm/cpu/armv7/omap-common/u-boot-spl.lds board/ait/cam_enc_4xx/u-boot-spl.lds board/davinci/da8xxevm/u-boot-spl-da850evm.lds board/davinci/da8xxevm/u-boot-spl-hawk.lds board/vpac270/u-boot-spl.ldsSigned-off-by: Albert ARIBAUD <albert.u.boot@aribaud.net>
common: Discard the __u_boot_cmd sectionThe command declaration now uses the new LG-array method to generatelist of commands. Thus the __u_boot_cmd section is now superseded andredundant and ther
common: Discard the __u_boot_cmd sectionThe command declaration now uses the new LG-array method to generatelist of commands. Thus the __u_boot_cmd section is now superseded andredundant and therefore can be removed. Also, remove externed symbolsassociated with this section from include/command.h .Signed-off-by: Marek Vasut <marex@denx.de>Cc: Joe Hershberger <joe.hershberger@gmail.com>Cc: Mike Frysinger <vapier@gentoo.org>
common: Add .u_boot_list into all linker filesAdd section for the linker-generated lists into all possible linkerfiles, so that everyone can easily use these lists. This is mostlya mechanical adj
common: Add .u_boot_list into all linker filesAdd section for the linker-generated lists into all possible linkerfiles, so that everyone can easily use these lists. This is mostlya mechanical adjustment.Signed-off-by: Marek Vasut <marex@denx.de>Cc: Joe Hershberger <joe.hershberger@gmail.com>Cc: Mike Frysinger <vapier@gentoo.org>
ColdFire: Clean up checkpatch warnings for MCF532x/MCF537x/MCF5301xSigned-off-by: Alison Wang <b18965@freescale.com>
doc: cleanup - move board READMEs into respective board directoriesAlso drop a few files referring to no longer / not yet supportedboards.Signed-off-by: Wolfgang Denk <wd@denx.de>Cc: Prafulla W
doc: cleanup - move board READMEs into respective board directoriesAlso drop a few files referring to no longer / not yet supportedboards.Signed-off-by: Wolfgang Denk <wd@denx.de>Cc: Prafulla Wadaskar <prafulla@marvell.com>Cc: Stefan Roese <sr@denx.de>Cc: Kim Phillips <kim.phillips@freescale.com>Cc: Andy Fleming <afleming@gmail.com>Cc: Jason Jin <jason.jin@freescale.com>Cc: Stefano Babic <sbabic@denx.de>Cc: Daniel Schwierzeck <daniel.schwierzeck@googlemail.com>Acked-by: Stefano Babic <sbabic@denx.de>Acked-by: Daniel Schwierzeck <daniel.schwierzeck@googlemail.com>
ColdFire: Cleanup for partial linking and --gc-sectionsIntroduce the --gc-sections for ColdFire platform and clean up thecorresponding lds file.Signed-off-by: TsiChung Liew <tsicliew@gmail.com>
ColdFire: Cleanup for partial linking and --gc-sectionsIntroduce the --gc-sections for ColdFire platform and clean up thecorresponding lds file.Signed-off-by: TsiChung Liew <tsicliew@gmail.com>Signed-off-by: Jason Jin <Jason.jin@freescale.com>
12