SPDX: Convert all of our single license tags to Linux Kernel styleWhen U-Boot started using SPDX tags we were among the early adopters andthere weren't a lot of other examples to borrow from. So
SPDX: Convert all of our single license tags to Linux Kernel styleWhen U-Boot started using SPDX tags we were among the early adopters andthere weren't a lot of other examples to borrow from. So we picked thearea of the file that usually had a full license text and replaced itwith an appropriate SPDX-License-Identifier: entry. Since then, theLinux Kernel has adopted SPDX tags and they place it as the very firstline in a file (except where shebangs are used, then it's second line)and with slightly different comment styles than us.In part due to community overlap, in part due to better tag visibilityand in part for other minor reasons, switch over to that style.This commit changes all instances where we have a single declaredlicense in the tag as both the before and after are identical in tagcontents. There's also a few places where I found we did not have a tagand have introduced one.Signed-off-by: Tom Rini <trini@konsulko.com>
show more ...
Remove unnecessary instances of DECLARE_GLOBAL_DATA_PTRWe have a large number of places where while we historically referencedgd in the code we no longer do, as well as cases where the code added
Remove unnecessary instances of DECLARE_GLOBAL_DATA_PTRWe have a large number of places where while we historically referencedgd in the code we no longer do, as well as cases where the code addedthat line "just in case" during development and never dropped it.Signed-off-by: Tom Rini <trini@konsulko.com>
libfdt: move headers to <linux/libfdt.h> and <linux/libfdt_env.h>Thomas reported U-Boot failed to build host tools if libfdt-develpackage is installed because tools include libfdt headers from/us
libfdt: move headers to <linux/libfdt.h> and <linux/libfdt_env.h>Thomas reported U-Boot failed to build host tools if libfdt-develpackage is installed because tools include libfdt headers from/usr/include/ instead of using internal ones.This commit moves the header code: include/libfdt.h -> include/linux/libfdt.h include/libfdt_env.h -> include/linux/libfdt_env.hand replaces include directives: #include <libfdt.h> -> #include <linux/libfdt.h> #include <libfdt_env.h> -> #include <linux/libfdt_env.h>Reported-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
drivers/misc: Share qbman init between archsThis patch adds changes necessary to move functionality present inPowerPC folders with ARM architectures that have DPAA1 QBMan hardware- Create new bo
drivers/misc: Share qbman init between archsThis patch adds changes necessary to move functionality present inPowerPC folders with ARM architectures that have DPAA1 QBMan hardware- Create new board/freescale/common/fsl_portals.c to house shared device tree fixups for DPAA1 devices with ARM and PowerPC cores- Add new header file to top includes directory to allow files in both architectures to grab the function prototypes- Port inhibit_portals() from PowerPC to ARM. This function is used in setup to disable interrupts on all QMan and BMan portals. It is needed because the interrupts are enabled by default for all portals including unused/uninitialised portals. When the kernel attempts to go to deep sleep the unused portals prevent it from doing soSigned-off-by: Ahmed Mansour <ahmed.mansour@nxp.com>Reviewed-by: York Sun <york.sun@nxp.com>
env: Rename some other getenv()-related functionsWe are now using an env_ prefix for environment functions. Rename theseother functions as well, for consistency: getenv_vlan() getenv_bootm_
env: Rename some other getenv()-related functionsWe are now using an env_ prefix for environment functions. Rename theseother functions as well, for consistency: getenv_vlan() getenv_bootm_size() getenv_bootm_low() getenv_bootm_mapsize() env_get_default()Suggested-by: Wolfgang Denk <wd@denx.de>Signed-off-by: Simon Glass <sjg@chromium.org>
env: Rename getenv/_f() to env_get()We are now using an env_ prefix for environment functions. Rename thesetwo functions for consistency. Also add function comments in common.h.Quite a few place
env: Rename getenv/_f() to env_get()We are now using an env_ prefix for environment functions. Rename thesetwo functions for consistency. Also add function comments in common.h.Quite a few places use getenv() in a condition context, provoking awarning from checkpatch. These are fixed up in this patch also.Suggested-by: Wolfgang Denk <wd@denx.de>Signed-off-by: Simon Glass <sjg@chromium.org>
env: Rename setenv() to env_set()We are now using an env_ prefix for environment functions. Rename setenv()for consistency. Also add function comments in common.h.Suggested-by: Wolfgang Denk <wd
env: Rename setenv() to env_set()We are now using an env_ prefix for environment functions. Rename setenv()for consistency. Also add function comments in common.h.Suggested-by: Wolfgang Denk <wd@denx.de>Signed-off-by: Simon Glass <sjg@chromium.org>
board_f: Rename initdram() to dram_init()This allows us to use the same DRAM init function on all archs. Add adummy function for arc, which does not use DRAM init here.Signed-off-by: Simon Glass
board_f: Rename initdram() to dram_init()This allows us to use the same DRAM init function on all archs. Add adummy function for arc, which does not use DRAM init here.Signed-off-by: Simon Glass <sjg@chromium.org>[trini: Dummy function on nios2]Signed-off-by: Tom Rini <trini@konsulko.com>
board_f: Drop return value from initdram()At present we cannot use this function as an init sequence call without awrapper, since it returns the RAM size. Adjust it to set the RAM size inglobal_d
board_f: Drop return value from initdram()At present we cannot use this function as an init sequence call without awrapper, since it returns the RAM size. Adjust it to set the RAM size inglobal_data instead, and return 0 on success.Signed-off-by: Simon Glass <sjg@chromium.org>Reviewed-by: Stefan Roese <sr@denx.de>
board_f: Drop board_type parameter from initdram()It looks like only cm5200 and tqm8xx use this feature, so we don't reallyneed it in generic code. Drop it and have the users access gd->board_type
board_f: Drop board_type parameter from initdram()It looks like only cm5200 and tqm8xx use this feature, so we don't reallyneed it in generic code. Drop it and have the users access gd->board_typedirectly.Signed-off-by: Simon Glass <sjg@chromium.org>Reviewed-by: Stefan Roese <sr@denx.de>
NXP: Introduce board/freescale/common/Kconfig and migrate CHAIN_OF_TRUSTIntroduce board/freescale/common/Kconfig so that we have a single placefor CONFIG options that are shared between ARM and Po
NXP: Introduce board/freescale/common/Kconfig and migrate CHAIN_OF_TRUSTIntroduce board/freescale/common/Kconfig so that we have a single placefor CONFIG options that are shared between ARM and PowerPC NXP platforms.Cc: York Sun <york.sun@nxp.com>Signed-off-by: Tom Rini <trini@konsulko.com>Reviewed-by: York Sun <york.sun@nxp.com>
powerpc: cyrus: Separate P5020/P5040 config optionsInstead of using EXTRA options in defconfig, use two targetsin Kconfig to select correct SoC.Signed-off-by: York Sun <york.sun@nxp.com>
powerpc: P5040: Remove macro CONFIG_P5040Replace CONFIG_P5040 with ARCH_P5040 in Kconfig and clean upexisting macros.Signed-off-by: York Sun <york.sun@nxp.com>
usb: fsl: Rename fdt_fixup_dr_usbThe function fdt_fixup_dr_usb is specific to fsl/nxp. So,make the function name explicit and rename fdt_fixup_dr_usbinto fsl_fdt_fixup_dr_usb.Signed-off-by: Sri
usb: fsl: Rename fdt_fixup_dr_usbThe function fdt_fixup_dr_usb is specific to fsl/nxp. So,make the function name explicit and rename fdt_fixup_dr_usbinto fsl_fdt_fixup_dr_usb.Signed-off-by: Sriram Dash <sriram.dash@nxp.com>
Various Makefiles: Add SPDX-License-Identifier tagsAfter consulting with some of the SPDX team, the conclusion is thatMakefiles are worth adding SPDX-License-Identifier tags too, and most ofours
Various Makefiles: Add SPDX-License-Identifier tagsAfter consulting with some of the SPDX team, the conclusion is thatMakefiles are worth adding SPDX-License-Identifier tags too, and most ofours have one. This adds tags to ones that lack them and converts a fewthat had full (or in one case, very partial) license blobs into theequivalent tag.Cc: Kate Stewart <kstewart@linuxfoundation.org>Signed-off-by: Tom Rini <trini@konsulko.com>
mpc85xx: Add support for the Varisys Cyrus boardThis board runs a P5020 or P5040 chip, and utilizesan EEPROM with similar formatting to the Freescale P5020DS.Large amounts of this code were deve
mpc85xx: Add support for the Varisys Cyrus boardThis board runs a P5020 or P5040 chip, and utilizesan EEPROM with similar formatting to the Freescale P5020DS.Large amounts of this code were developed byAdrian Cox <adrian at humboldt dot co dot uk>Signed-off-by: Andy Fleming <afleming@gmail.com>Reviewed-by: York Sun <yorksun@freescale.com>