1SUMMARY = "HTTP/2 C Library and tools"
2HOMEPAGE = "https://nghttp2.org/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=764abdf30b2eadd37ce47dcbce0ea1ec"
6
7SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/nghttp2-${PV}.tar.xz"
8SRC_URI[sha256sum] = "26798308fa0a12dabdb7ba8c77f74383019d3a0f1f36d25958b836af22474958"
9
10inherit cmake manpages python3native github-releases
11PACKAGECONFIG[manpages] = ""
12
13# examples are never installed, and don't need to be built in the
14# first place
15EXTRA_OECMAKE = "-DENABLE_EXAMPLES=OFF -DENABLE_APP=OFF -DENABLE_HPACK_TOOLS=OFF -DENABLE_PYTHON_BINDINGS=OFF"
16
17PACKAGES =+ "lib${BPN} ${PN}-proxy "
18
19RDEPENDS:${PN} = "${PN}-proxy (>= ${PV})"
20RDEPENDS:${PN}:class-native = ""
21RDEPENDS:${PN}-proxy = "openssl python3-core python3-io python3-shell"
22
23ALLOW_EMPTY:${PN} = "1"
24FILES:${PN} = ""
25FILES:lib${BPN} = "${libdir}/*${SOLIBS}"
26FILES:${PN}-proxy = "${bindir}/nghttpx ${datadir}/${BPN}/fetch-ocsp-response"
27
28BBCLASSEXTEND = "native nativesdk"
29