1SUMMARY = "Custom Matchbox session files for the Sato environment"
2HOMEPAGE = "http://www.matchbox-project.org/"
3BUGTRACKER = "http://bugzilla.yoctoproject.org/"
4
5LICENSE = "GPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://session;endline=3;md5=f8a5c5b9c279e52dc094d10e11c2be63"
7
8SECTION = "x11"
9RDEPENDS:${PN} = "formfactor matchbox-theme-sato matchbox-panel-2 matchbox-desktop matchbox-session gconf"
10
11# This package is architecture specific because the session script is modified
12# based on the machine architecture.
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14
15inherit features_check
16
17# The matchbox-theme-sato requires x11 in DISTRO_FEATURES
18REQUIRED_DISTRO_FEATURES = "x11"
19
20SRC_URI = "file://session \
21           file://index.theme"
22
23S = "${WORKDIR}/sources"
24UNPACKDIR = "${S}"
25
26FILES:${PN} += "${datadir}/themes/Sato/index.theme"
27
28do_install() {
29	# This is the set of machine features that the script has markers for
30	FEATURES="acpi phone"
31	SCRIPT="${S}/sedder"
32	rm -f $SCRIPT
33	touch $SCRIPT
34	for FEAT in $FEATURES; do
35		if echo ${MACHINE_FEATURES} | awk "/$FEAT/ {exit 1}"; then
36			echo "/feature-$FEAT/d" >> $SCRIPT
37		fi
38	done
39
40	install -D ${S}/index.theme ${D}/${datadir}/themes/Sato/index.theme
41	install -d ${D}/${sysconfdir}/matchbox
42	sed -f "$SCRIPT" ${S}/session > ${D}/${sysconfdir}/matchbox/session
43        chmod +x ${D}/${sysconfdir}/matchbox/session
44}
45
46PACKAGE_WRITE_DEPS += "gconf-native"
47pkg_postinst:${PN} () {
48	set_value() {
49		#type, name, value
50		gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type $1 --set /desktop/poky/interface/$2 "$3"
51	}
52	set_value string theme Adwaita
53	set_value string matchbox_theme Sato
54	set_value string icon_theme Sato
55	set_value bool touchscreen true
56	set_value string font_name "Sans 9"
57}
58