1SUMMARY = "Custom Matchbox session files for the Sato environment"
2HOMEPAGE = "http://www.matchbox-project.org/"
3BUGTRACKER = "http://bugzilla.yoctoproject.org/"
4
5LICENSE = "GPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://session;endline=3;md5=f8a5c5b9c279e52dc094d10e11c2be63"
7
8SECTION = "x11"
9RDEPENDS:${PN} = "formfactor matchbox-theme-sato matchbox-panel-2 matchbox-desktop matchbox-session gconf"
10
11# This package is architecture specific because the session script is modified
12# based on the machine architecture.
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14
15inherit features_check
16
17# The matchbox-theme-sato requires x11 in DISTRO_FEATURES
18REQUIRED_DISTRO_FEATURES = "x11"
19
20SRC_URI = "file://session \
21           file://index.theme"
22S = "${WORKDIR}"
23
24FILES:${PN} += "${datadir}/themes/Sato/index.theme"
25
26do_install() {
27	# This is the set of machine features that the script has markers for
28	FEATURES="acpi phone"
29	SCRIPT="${S}/sedder"
30	rm -f $SCRIPT
31	touch $SCRIPT
32	for FEAT in $FEATURES; do
33		if echo ${MACHINE_FEATURES} | awk "/$FEAT/ {exit 1}"; then
34			echo "/feature-$FEAT/d" >> $SCRIPT
35		fi
36	done
37
38	install -D ${S}/index.theme ${D}/${datadir}/themes/Sato/index.theme
39	install -d ${D}/${sysconfdir}/matchbox
40	sed -f "$SCRIPT" ${S}/session > ${D}/${sysconfdir}/matchbox/session
41        chmod +x ${D}/${sysconfdir}/matchbox/session
42}
43
44PACKAGE_WRITE_DEPS += "gconf-native"
45pkg_postinst:${PN} () {
46	set_value() {
47		#type, name, value
48		gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type $1 --set /desktop/poky/interface/$2 "$3"
49	}
50	set_value string theme Adwaita
51	set_value string matchbox_theme Sato
52	set_value string icon_theme Sato
53	set_value bool touchscreen true
54	set_value string font_name "Sans 9"
55}
56