1eb8dc403SDave CobbleySUMMARY = "Custom Matchbox session files for the Sato environment"
2eb8dc403SDave CobbleyHOMEPAGE = "http://www.matchbox-project.org/"
3eb8dc403SDave CobbleyBUGTRACKER = "http://bugzilla.yoctoproject.org/"
4eb8dc403SDave Cobbley
5eb8dc403SDave CobbleyLICENSE = "GPLv2.0+"
6eb8dc403SDave CobbleyLIC_FILES_CHKSUM = "file://session;endline=3;md5=f8a5c5b9c279e52dc094d10e11c2be63"
7eb8dc403SDave Cobbley
8eb8dc403SDave CobbleySECTION = "x11"
9*213cb269SPatrick WilliamsRDEPENDS:${PN} = "formfactor matchbox-theme-sato matchbox-panel-2 matchbox-desktop matchbox-session gconf"
10eb8dc403SDave CobbleyPR = "r30"
11eb8dc403SDave Cobbley
12eb8dc403SDave Cobbley# This package is architecture specific because the session script is modified
13eb8dc403SDave Cobbley# based on the machine architecture.
14eb8dc403SDave CobbleyPACKAGE_ARCH = "${MACHINE_ARCH}"
15eb8dc403SDave Cobbley
166dbb316aSBrad Bishopinherit features_check
17eb8dc403SDave Cobbley
18eb8dc403SDave Cobbley# The matchbox-theme-sato requires x11 in DISTRO_FEATURES
19eb8dc403SDave CobbleyREQUIRED_DISTRO_FEATURES = "x11"
20eb8dc403SDave Cobbley
21eb8dc403SDave CobbleySRC_URI = "file://session \
22eb8dc403SDave Cobbley           file://index.theme"
23eb8dc403SDave CobbleyS = "${WORKDIR}"
24eb8dc403SDave Cobbley
25*213cb269SPatrick WilliamsFILES:${PN} += "${datadir}/themes/Sato/index.theme"
26eb8dc403SDave Cobbley
27eb8dc403SDave Cobbleydo_install() {
28eb8dc403SDave Cobbley	# This is the set of machine features that the script has markers for
291a4b7ee2SBrad Bishop	FEATURES="acpi apm phone"
30eb8dc403SDave Cobbley	SCRIPT="${S}/sedder"
31eb8dc403SDave Cobbley	rm -f $SCRIPT
32eb8dc403SDave Cobbley	touch $SCRIPT
33eb8dc403SDave Cobbley	for FEAT in $FEATURES; do
34eb8dc403SDave Cobbley		if echo ${MACHINE_FEATURES} | awk "/$FEAT/ {exit 1}"; then
35eb8dc403SDave Cobbley			echo "/feature-$FEAT/d" >> $SCRIPT
36eb8dc403SDave Cobbley		fi
37eb8dc403SDave Cobbley	done
38eb8dc403SDave Cobbley
39eb8dc403SDave Cobbley	install -D ${S}/index.theme ${D}/${datadir}/themes/Sato/index.theme
40eb8dc403SDave Cobbley	install -d ${D}/${sysconfdir}/matchbox
41eb8dc403SDave Cobbley	sed -f "$SCRIPT" ${S}/session > ${D}/${sysconfdir}/matchbox/session
42eb8dc403SDave Cobbley        chmod +x ${D}/${sysconfdir}/matchbox/session
43eb8dc403SDave Cobbley}
44eb8dc403SDave Cobbley
45eb8dc403SDave CobbleyPACKAGE_WRITE_DEPS += "gconf-native"
46*213cb269SPatrick Williamspkg_postinst:${PN} () {
47eb8dc403SDave Cobbley	set_value() {
48eb8dc403SDave Cobbley		#type, name, value
49eb8dc403SDave Cobbley		gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type $1 --set /desktop/poky/interface/$2 "$3"
50eb8dc403SDave Cobbley	}
51eb8dc403SDave Cobbley	set_value string theme Adwaita
52eb8dc403SDave Cobbley	set_value string matchbox_theme Sato
53eb8dc403SDave Cobbley	set_value string icon_theme Sato
54eb8dc403SDave Cobbley	set_value bool touchscreen true
55eb8dc403SDave Cobbley	set_value string font_name "Sans 9"
56eb8dc403SDave Cobbley}
57