1inherit setuptools3
2require python-cython.inc
3
4RDEPENDS:${PN} += "\
5    python3-setuptools \
6"
7
8# running build_ext a second time during install fails, because Python
9# would then attempt to import cythonized modules built for the target
10# architecture.
11SETUPTOOLS_INSTALL_ARGS += "--skip-build"
12
13do_install:append() {
14    # rename scripts that would conflict with the Python 2 build of Cython
15    mv ${D}${bindir}/cython ${D}${bindir}/cython3
16    mv ${D}${bindir}/cythonize ${D}${bindir}/cythonize3
17    mv ${D}${bindir}/cygdb ${D}${bindir}/cygdb3
18}
19
20PACKAGESPLITFUNCS =+ "cython_fix_sources"
21
22cython_fix_sources () {
23	for f in ${PKGD}${TARGET_DBGSRC_DIR}/Cython/Compiler/FlowControl.c \
24		${PKGD}${TARGET_DBGSRC_DIR}/Cython/Compiler/FusedNode.c \
25		${PKGD}${TARGET_DBGSRC_DIR}/Cython/Compiler/Scanning.c \
26		${PKGD}${TARGET_DBGSRC_DIR}/Cython/Compiler/Visitor.c \
27		${PKGD}${TARGET_DBGSRC_DIR}/Cython/Plex/Actions.c \
28		${PKGD}${TARGET_DBGSRC_DIR}/Cython/Plex/Scanners.c \
29		${PKGD}${TARGET_DBGSRC_DIR}/Cython/Runtime/refnanny.c \
30		${PKGD}${TARGET_DBGSRC_DIR}/Cython/Tempita/_tempita.c \
31		${PKGD}${libdir}/${PYTHON_DIR}/site-packages/Cython*/SOURCES.txt; do
32		if [ -e $f ]; then
33			sed -i -e 's#${WORKDIR}/Cython-${PV}#${TARGET_DBGSRC_DIR}#g' $f
34		fi
35	done
36}
37
38