1require newlib.inc
2
3DEPENDS += "newlib"
4
5FILESEXTRAPATHS:prepend := "${THISDIR}/libgloss:"
6
7SRC_URI:append = " file://libgloss-build-without-nostdinc.patch"
8SRC_URI:append:powerpc = " file://fix-rs6000-crt0.patch"
9SRC_URI:append:powerpc = " file://fix-rs6000-cflags.patch"
10
11do_configure() {
12	${S}/libgloss/configure ${EXTRA_OECONF}
13}
14
15do_install:prepend() {
16	# install doesn't create this itself, avoid install error
17	install -d ${D}${prefix}/${TARGET_SYS}/lib
18}
19
20do_install:append() {
21	# Move libs to default directories so they can be picked up later
22	install -d ${D}${libdir}
23	mv -v ${D}${prefix}/${TARGET_SYS}/lib/* ${D}${libdir}
24
25	# Remove original directory
26	rmdir -p --ignore-fail-on-non-empty ${D}${prefix}/${TARGET_SYS}/lib
27}
28
29# Split packages correctly
30FILES:${PN} += "${libdir}/*.ld ${libdir}/*.specs"
31FILES:${PN}-dev += "${libdir}/cpu-init/*"
32# RiscV installation moved the syscall header to this location
33FILES:${PN}-dev += "${prefix}/${TARGET_SYS}/include/machine/*.h"
34
35INHIBIT_PACKAGE_STRIP = "1"
36INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
37