1SUMMARY = "nl80211 based CLI configuration utility for wireless devices"
2DESCRIPTION = "iw is a new nl80211 based CLI configuration utility for \
3wireless devices. It supports almost all new drivers that have been added \
4to the kernel recently. "
5HOMEPAGE = "https://wireless.wiki.kernel.org/en/users/documentation/iw"
6SECTION = "base"
7LICENSE = "BSD-2-Clause"
8LIC_FILES_CHKSUM = "file://COPYING;md5=878618a5c4af25e9b93ef0be1a93f774"
9
10DEPENDS = "libnl"
11
12SRC_URI = "http://www.kernel.org/pub/software/network/iw/${BP}.tar.gz \
13           file://0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch \
14           file://separate-objdir.patch \
15"
16
17SRC_URI[sha256sum] = "4c3194778b175d58442907d51d1977e7270fce5cbebff0eab11c45c1da287a4b"
18
19inherit pkgconfig
20
21EXTRA_OEMAKE = "\
22    -f '${S}/Makefile' \
23    \
24    'PREFIX=${prefix}' \
25    'SBINDIR=${sbindir}' \
26    'MANDIR=${mandir}' \
27"
28
29do_install() {
30    oe_runmake 'DESTDIR=${D}' install
31}
32