1SUMMARY = "U-Boot libraries and tools to access environment"
2
3DESCRIPTION = "This package contains tools and libraries to read \
4and modify U-Boot environment. \
5It provides a hardware-independent replacement for fw_printenv/setenv utilities \
6provided by U-Boot"
7
8HOMEPAGE = "https://github.com/sbabic/libubootenv"
9LICENSE = "LGPL-2.1-or-later"
10LIC_FILES_CHKSUM = "file://LICENSES/LGPL-2.1-or-later.txt;md5=4fbd65380cdd255951079008b364516c"
11SECTION = "libs"
12
13SRC_URI = "git://github.com/sbabic/libubootenv;protocol=https;branch=master"
14SRCREV = "3f4d15e36ceb58085b08dd13f3f2788e9299877b"
15
16S = "${WORKDIR}/git"
17
18inherit cmake lib_package
19
20EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release"
21
22DEPENDS = "zlib libyaml"
23PROVIDES += "u-boot-fw-utils"
24RPROVIDES:${PN}-bin += "u-boot-fw-utils"
25
26BBCLASSEXTEND = "native"
27