1SUMMARY = "Device formfactor information"
2DESCRIPTION = "A formfactor configuration file provides information about the \
3target hardware for which the image is being built and information that the \
4build system cannot obtain from other sources such as the kernel."
5SECTION = "base"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
8PR = "r45"
9
10SRC_URI = "file://config file://machconfig"
11S = "${WORKDIR}"
12
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14INHIBIT_DEFAULT_DEPS = "1"
15
16do_install() {
17	# Install file only if it has contents
18        install -d ${D}${sysconfdir}/formfactor/
19        install -m 0644 ${S}/config ${D}${sysconfdir}/formfactor/
20	if [ -s "${S}/machconfig" ]; then
21	        install -m 0644 ${S}/machconfig ${D}${sysconfdir}/formfactor/
22	fi
23}
24