1SUMMARY = "Device formfactor information"
2DESCRIPTION = "A formfactor configuration file provides information about the \
3target hardware for which the image is being built and information that the \
4build system cannot obtain from other sources such as the kernel."
5SECTION = "base"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
8
9SRC_URI = "file://config file://machconfig"
10S = "${WORKDIR}"
11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13INHIBIT_DEFAULT_DEPS = "1"
14
15do_install() {
16	# Install file only if it has contents
17        install -d ${D}${sysconfdir}/formfactor/
18        install -m 0644 ${S}/config ${D}${sysconfdir}/formfactor/
19	if [ -s "${S}/machconfig" ]; then
20	        install -m 0644 ${S}/machconfig ${D}${sysconfdir}/formfactor/
21	fi
22}
23