19eeb80ffSEd Tanous#This is largely to improve our build times by not building or installing
256a8292bSAndrew Geissler#modules that OpenBMC does not use by our coding standard.  Another thing to
356a8292bSAndrew Geissler#note is that for most targets, coroutine and context libraries are also added
4*12fc939cSPatrick Williams#with a BOOST_LIBS:append:<platform> for most targets.  Chrono/Thread should not
556a8292bSAndrew Geissler#be relied directly, but are required dependencies of context and coroutine.
656a8292bSAndrew Geissler#See the relevant portion of the openbmc coding standard with regards to boost
756a8292bSAndrew Geissler#libraries
89eeb80ffSEd Tanous#
99eeb80ffSEd Tanous#https://github.com/openbmc/docs/blob/master/cpp-style-and-conventions.md#boost
109eeb80ffSEd Tanous#
11*12fc939cSPatrick WilliamsBOOST_LIBS:openbmc-phosphor = "chrono thread context coroutine"
129eeb80ffSEd Tanous
13