1PACKAGECONFIG:openbmc-phosphor:class-target = ""
2
3#This is largely to improve our build times by not building or installing
4#modules that OpenBMC does not use by our coding standard.  Another thing to
5#note is that for most targets, coroutine and context libraries are also added
6#with a BOOST_LIBS:append:<platform> for most targets.  Chrono/Thread should not
7#be relied directly, but are required dependencies of context and coroutine.
8#See the relevant portion of the openbmc coding standard with regards to boost
9#libraries
10#
11#https://github.com/openbmc/docs/blob/master/cpp-style-and-conventions.md#boost
12#
13BOOST_LIBS:openbmc-phosphor:class-target = "chrono thread context coroutine url"
14
15BOOST_LIBS:openbmc-phosphor:class-target:append:df-etcd = " \
16             random system filesystem atomic date_time regex"
17