1*ff075f6eSBrad BishopSUMMARY = "FRU properties config for ipmi-fru-parser"
2*ff075f6eSBrad BishopPR = "r1"
3*ff075f6eSBrad Bishop
4*ff075f6eSBrad Bishopinherit native
5*ff075f6eSBrad Bishopinherit obmc-phosphor-license
6*ff075f6eSBrad Bishopinherit phosphor-ipmi-fru
7*ff075f6eSBrad Bishop
8*ff075f6eSBrad BishopSRC_URI += "file://extra-properties.yaml"
9*ff075f6eSBrad Bishop
10*ff075f6eSBrad BishopPROVIDES += "virtual/phosphor-ipmi-fru-properties"
11*ff075f6eSBrad Bishop
12*ff075f6eSBrad BishopS = "${WORKDIR}"
13*ff075f6eSBrad Bishop
14*ff075f6eSBrad Bishopdo_install() {
15*ff075f6eSBrad Bishop        # This recipe is supposed to create an output yaml file with
16*ff075f6eSBrad Bishop        # FRU property values extracted from the MRW. This example recipe
17*ff075f6eSBrad Bishop        # provides a sample output file.
18*ff075f6eSBrad Bishop
19*ff075f6eSBrad Bishop        DEST=${D}${properties_datadir}
20*ff075f6eSBrad Bishop        install -d ${DEST}
21*ff075f6eSBrad Bishop        install extra-properties.yaml ${DEST}
22*ff075f6eSBrad Bishop}
23