1ff075f6eSBrad BishopSUMMARY = "FRU properties config for ipmi-fru-parser"
275f0387bSBrad BishopLICENSE = "Apache-2.0"
36f3f0aa7SBrad BishopLIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
4*9936f86dSEd TanousPROVIDES += "virtual/phosphor-ipmi-fru-properties"
5*9936f86dSEd TanousPR = "r1"
6ff075f6eSBrad Bishop
7ff075f6eSBrad BishopSRC_URI += "file://extra-properties.yaml"
8ff075f6eSBrad Bishop
9ff075f6eSBrad BishopS = "${WORKDIR}"
10ff075f6eSBrad Bishop
11*9936f86dSEd Tanousinherit phosphor-ipmi-fru
12*9936f86dSEd Tanousinherit native
13*9936f86dSEd Tanous
14ff075f6eSBrad Bishopdo_install() {
15ff075f6eSBrad Bishop        # This recipe is supposed to create an output yaml file with
16ff075f6eSBrad Bishop        # FRU property values extracted from the MRW. This example recipe
17ff075f6eSBrad Bishop        # provides a sample output file.
18ff075f6eSBrad Bishop        DEST=${D}${properties_datadir}
19ff075f6eSBrad Bishop        install -d ${DEST}
20ff075f6eSBrad Bishop        install extra-properties.yaml ${DEST}
21ff075f6eSBrad Bishop}
22