1ff075f6eSBrad BishopSUMMARY = "FRU properties config for ipmi-fru-parser"
275f0387bSBrad BishopLICENSE = "Apache-2.0"
36f3f0aa7SBrad BishopLIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
49936f86dSEd TanousPROVIDES += "virtual/phosphor-ipmi-fru-properties"
59936f86dSEd TanousPR = "r1"
6ff075f6eSBrad Bishop
7ff075f6eSBrad BishopSRC_URI += "file://extra-properties.yaml"
8ff075f6eSBrad Bishop
9*91a1cec2SAndrew GeisslerS = "${WORKDIR}/sources"
10*91a1cec2SAndrew GeisslerUNPACKDIR = "${S}"
11ff075f6eSBrad Bishop
129936f86dSEd Tanousinherit phosphor-ipmi-fru
139936f86dSEd Tanousinherit native
149936f86dSEd Tanous
15ff075f6eSBrad Bishopdo_install() {
16ff075f6eSBrad Bishop        # This recipe is supposed to create an output yaml file with
17ff075f6eSBrad Bishop        # FRU property values extracted from the MRW. This example recipe
18ff075f6eSBrad Bishop        # provides a sample output file.
19ff075f6eSBrad Bishop        DEST=${D}${properties_datadir}
20ff075f6eSBrad Bishop        install -d ${DEST}
21ff075f6eSBrad Bishop        install extra-properties.yaml ${DEST}
22ff075f6eSBrad Bishop}
23