1SUMMARY = "Websocket module for Apache web server"
2DESCRIPTION = "Process requests using the WebSocket protocol (RFC 6455)"
3HOMEPAGE = "https://github.com/jchampio/apache-websocket/"
4SECTION = "net"
5LICENSE = "Apache-2.0"
6
7inherit autotools-brokensep pkgconfig
8
9DEPENDS = "apache2 apache2-native pbzip2-native"
10RDEPENDS_${PN} += "apache2"
11
12# Original (github.com/disconnect/apache-websocket) is dead since 2012, the
13# fork contains patches from the modules ML and fixes CVE compliance issues
14SRC_URI = "git://github.com/jchampio/apache-websocket.git"
15
16SRCREV = "0ee34c77fc78ff08fd548706300b80a7bc7874e4"
17
18PV = "0.1.2+git${SRCPV}"
19
20S = "${WORKDIR}/git"
21
22LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
23
24EXTRA_OECONF = "APACHECTL=${STAGING_DIR_TARGET}${sbindir}/apachectl \
25                LIBTOOL=${STAGING_DIR_TARGET}${bindir_crossscripts}/${HOST_SYS}-libtool"
26
27do_install() {
28    install -d ${D}${libexecdir}/apache2/modules
29    install -m 755 ${B}/.libs/mod_websocket.so ${D}${libexecdir}/apache2/modules
30}
31
32FILES_${PN} += " ${libexecdir}/apache2/modules/* "
33FILES_${PN}-dbg += " ${libexecdir}/apache2/modules/.debug/* "
34