1SUMMARY = "Websocket module for Apache web server"
2DESCRIPTION = "Process requests using the WebSocket protocol (RFC 6455)"
3HOMEPAGE = "https://github.com/jchampio/apache-websocket/"
4SECTION = "net"
5LICENSE = "Apache-2.0"
6
7inherit autotools-brokensep pkgconfig
8
9DEPENDS = "apache2 apache2-native pbzip2-native"
10RDEPENDS:${PN} += "apache2"
11
12# Original (github.com/disconnect/apache-websocket) is dead since 2012, the
13# fork contains patches from the modules ML and fixes CVE compliance issues
14SRC_URI = "git://github.com/jchampio/apache-websocket.git;branch=master;protocol=https"
15
16SRCREV = "0ee34c77fc78ff08fd548706300b80a7bc7874e4"
17
18PV = "0.1.2+git"
19
20S = "${WORKDIR}/git"
21
22LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
23
24EXTRA_OECONF = "APACHECTL=${STAGING_DIR_TARGET}${sbindir}/apachectl"
25
26do_install() {
27    install -d ${D}${libexecdir}/apache2/modules
28    install -m 755 ${B}/.libs/mod_websocket.so ${D}${libexecdir}/apache2/modules
29}
30
31FILES:${PN} += " ${libexecdir}/apache2/modules/* "
32FILES:${PN}-dbg += " ${libexecdir}/apache2/modules/.debug/* "
33