1DESCRIPTION = "GUI tool for storage configuration using blivet library"
2HOMEPAGE = "https://github.com/rhinstaller/blivet-gui"
3LICENSE = "GPL-2.0-or-later"
4SECTION = "devel/python"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8SRC_URI = "git://github.com/storaged-project/blivet-gui.git;branch=main;protocol=https"
9SRCREV = "626b44610a30ad26734dd20642538caab5a9178a"
10
11S = "${WORKDIR}/git"
12
13inherit features_check setuptools3
14REQUIRED_DISTRO_FEATURES = "x11 systemd gobject-introspection-data"
15
16RDEPENDS:${PN} = "python3-pygobject python3 \
17                  python3-blivet gtk+3  \
18                  python3-pid libreport \
19"
20
21FILES:${PN} += "${datadir}/*"
22