1DESCRIPTION = "Bindings for the scrypt key derivation function library"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=05b5ac2824a7ae7489193b0f6a6f2cd1"
4HOMEPAGE="https://github.com/holgern/py-scrypt"
5
6SRC_URI += "file://0001-py-scrypt-remove-the-hard-coded-include-paths.patch"
7
8SRC_URI[sha256sum] = "98ffde45e4a95461d73ded54ba7a26857679920d4f8ff320f6f7ade6e29531bd"
9
10inherit pypi ptest setuptools3 dos2unix
11
12SRC_URI += " \
13    file://run-ptest \
14"
15
16RDEPENDS:${PN}-ptest += " \
17    python3-pytest \
18    python3-unittest-automake-output \
19"
20
21RDEPENDS:${PN} += " \
22    python3-ctypes \
23"
24
25do_install_ptest() {
26    install -d ${D}${PTEST_PATH}/tests
27    cp -rf ${S}/scrypt/tests/* ${D}${PTEST_PATH}/tests/
28}
29