1SUMMARY = "Python wrapper around rapidjson"
2HOMEPAGE = "https://github.com/python-rapidjson/python-rapidjson"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4daf3929156304df67003c33274a98bd"
6
7SRC_URI[sha256sum] = "26806f0a658c34b48d2951d8d3f846ca9deb93a34e664ef436db632a188b6779"
8
9# Inheriting ptest provides functionality for packaging and installing runtime tests for this recipe
10inherit setuptools3 pypi ptest
11
12PYPI_PACKAGE = "python-rapidjson"
13
14SETUPTOOLS_BUILD_ARGS += " --rj-include-dir=${RECIPE_SYSROOT}${includedir}"
15
16# run-ptest is a shell script that starts the test suite
17SRC_URI += " \
18    file://run-ptest \
19"
20
21DEPENDS += " \
22    rapidjson \
23"
24
25# Adding required python package for the ptest (pytest and pytest->automake report translation)
26RDEPENDS:${PN}-ptest += " \
27    python3-pytest \
28    python3-unittest-automake-output \
29    python3-pytz \
30"
31
32RDEPENDS:${PN} += " \
33    python3-core \
34"
35
36# Installing the test suite on the target
37do_install_ptest() {
38    install -d ${D}${PTEST_PATH}/tests
39    cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
40}
41