1SUMMARY = "WSGI HTTP Server for UNIX"
2
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=302423eeae97079c633da81b6a5fe35e"
5
6SRC_URI[sha256sum] = "88ec8bff1d634f98e61b9f65bc4bf3cd918a90806c6f5c48bc5603849ec81033"
7
8inherit pypi setuptools3 ptest
9
10SRC_URI += " \
11	file://run-ptest \
12"
13
14RDEPENDS:${PN}-ptest += " \
15    python3-eventlet \
16    python3-gevent \
17    python3-pytest \
18    python3-unittest-automake-output \
19"
20
21do_install_ptest() {
22	install -d ${D}${PTEST_PATH}/tests
23	cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
24}
25
26RDEPENDS:${PN} += "python3-setuptools python3-fcntl"
27