1SUMMARY = "Doing dirty (but extremely useful) things with equals."
2DESCRIPTION = "dirty-equals is a python library that (mis)uses the \
3__eq__ method to make python code (generally unit tests) more \
4declarative and therefore easier to read and write.\
5\
6dirty-equals can be used in whatever context you like, but it comes \
7into its own when writing unit tests for applications where you're \
8commonly checking the response to API calls and the contents of a database."
9HOMEPAGE = "https://github.com/samuelcolvin/dirty-equals"
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=ab599c188b4a314d2856b3a55030c75c"
12
13SRC_URI[sha256sum] = "a580513f3285e93656a770a04e428f8bfc513848877bf278282dbfbb907fdbb4"
14
15S = "${WORKDIR}/dirty_equals-${PV}"
16
17inherit pypi python_hatchling
18
19PYPI_PACKAGE = "dirty_equals"
20
21RDEPENDS:${PN} += "python3-pytz"
22