1SUMMARY = "Simple construction, analysis and modification of binary data."
2HOMEPAGE = "https://github.com/scott-griffiths/bitstring"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=661f450e2c0aef39b4b15597333444a7"
5
6SRC_URI[sha256sum] = "94f3f1c45383ebe8fd4a359424ffeb75c2f290760ae8fcac421b44f89ac85213"
7
8PYPI_PACKAGE = "bitstring"
9
10inherit pypi python_poetry_core
11
12RDEPENDS:${PN} = "\
13    python3-core \
14    python3-io \
15    python3-mmap \
16    python3-numbers \
17"
18
19BBCLASSEXTEND = "native nativesdk"
20