1SUMMARY = "Firmware analysis tool"
2DESCRIPTION = "This package contains Python Binwalk tool. Binwalk is a fast, \
3easy to use tool for analyzing, reverse engineering, and extracting firmware \
4images."
5HOMEPAGE = "https://github.com/ReFirmLabs/binwalk"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=65bbee055d3ea3bfc475f07aecf4de64"
8
9SRC_URI = "git://github.com/ReFirmLabs/binwalk;protocol=https;branch=master"
10
11SRCREV = "cddfede795971045d99422bd7a9676c8803ec5ee"
12
13S = "${WORKDIR}/git"
14
15UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
16
17inherit setuptools3
18
19RDEPENDS:${PN} += " \
20    python3-compression \
21    python3-logging \
22    python3-netserver \
23    python3-setuptools \
24    python3-stringold \
25"
26