1SUMMARY = "Mock out requests made by ClientSession from aiohttp package"
2HOMEPAGE = "https://github.com/pnuckowski/aioresponses"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b22b40d5974300051216633098387c57"
5
6SRC_URI[sha256sum] = "66292f1d5c94a3cb984f3336d806446042adb17347d3089f2d3962dd6e5ba55a"
7
8DEPENDS += "python3-pbr-native"
9
10inherit setuptools3 pypi
11
12RDEPENDS:${PN} += "python3-aiohttp \
13                   python3-asyncio \
14                   python3-core \
15                   python3-json \
16                   python3-math \
17                   python3-multidict \
18                   python3-netclient \
19                   python3-packaging \
20                   python3-unittest \
21                   python3-yarl"
22
23# optionally needs asynctest asynctest.case ddt but recipes do not exist for them
24
25PYPI_PACKAGE = "aioresponses"
26