1SUMMARY = "Some tools to be used with smart cards and PC/SC"
2HOMEPAGE = "http://ludovic.rousseau.free.fr/softwares/pcsc-tools"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://LICENCE;md5=94d55d512a9ba36caa9b7df079bae19f"
5
6SRC_URI = "git://github.com/LudovicRousseau/pcsc-tools;protocol=https;branch=master"
7
8SRCREV = "778da3d86a59f5166443118c158e11ba4da9a5f1"
9
10inherit autotools pkgconfig
11
12S = "${WORKDIR}/git"
13
14DEPENDS = "pcsc-lite autoconf-archive-native"
15
16RDEPENDS:${PN} += " \
17	${@bb.utils.contains('DISTRO_FEATURES','systemd','pcsc-lite-systemd', 'pcsc-lite', d)} \
18	perl \
19	perl-module-getopt-std \
20	perl-module-file-stat \
21	libpcsc-perl \
22"
23
24FILES:${PN} += "${datadir}/pcsc/smartcard_list.txt \
25		${datadir}/pcsc/gscriptor.png"
26