1SUMMARY = "iODBC driver manager maintained by OpenLink Software."
2
3DESCRIPTION = "This kit will provide you with everything you need to \
4develop ODBC-compliant applications under Unix without having to pay \
5royalties to other parties. \
6"
7
8HOMEPAGE = "http://www.iodbc.org/"
9
10LICENSE = "LGPL-2.0-only | BSD-2-Clause"
11LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=8c0138a8701f0e1282f5c8b2c7d39114 \
12                    file://LICENSE.BSD;md5=ff3a66a194e500df485da930da7f2c62 \
13                    "
14
15SRC_URI = "https://github.com/openlink/iODBC/releases/download/v${PV}/${BP}.tar.gz"
16SRC_URI[sha256sum] = "c74541e3327fc9a1c7ccf103645471c67bc014542d70f572476eb07c0b2dd43c"
17
18inherit autotools
19
20EXTRA_OECONF += " --prefix=/usr/local \
21		--includedir=/usr/include/iodbc \
22		--with-iodbc-inidir=/etc \
23		--enable-odbc3 \
24		--enable-pthreads \
25		--disable-libodbc \
26		--disable-static \
27		"
28
29inherit multilib_script
30MULTILIB_SCRIPTS = "${PN}:${bindir}/iodbc-config"
31