1DESCRIPTION = "The gflags package contains a C++ library that implements commandline flags processing. It includes built-in support for standard types such as string and the ability to define flags in the source file in which they are used"
2HOMEPAGE = "https://github.com/gflags/gflags"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://COPYING.txt;md5=c80d1a3b623f72bb85a4c75b556551df"
5
6SRC_URI = "git://github.com/gflags/gflags.git;branch=master;protocol=https"
7SRCREV = "e171aa2d15ed9eb17054558e0b3a6a413bb01067"
8
9S = "${WORKDIR}/git"
10
11inherit cmake
12
13EXTRA_OECMAKE="-DBUILD_SHARED_LIBS=ON -DREGISTER_INSTALL_PREFIX=OFF -DLIB_INSTALL_DIR=${baselib}"
14
15PACKAGES =+ "${PN}-bash-completion"
16FILES:${PN}-bash-completion += "${bindir}/gflags_completions.sh"
17
18RDEPENDS:${PN}-bash-completion = "bash bash-completion"
19
20BBCLASSEXTEND = "native nativesdk"
21