1SUMMARY = "Tools to handle creating and mounting composefs images"
2DESCRIPTION = "The composefs project combines several underlying Linux \
3features to provide a very flexible mechanism to support read-only mountable \
4filesystem trees, stacking on top of an underlying "lower" Linux filesystem."
5HOMEPAGE = "https://github.com/containers/composefs"
6LICENSE = "GPL-3.0-or-later & LGPL-2.0-or-later & Apache-2.0"
7LIC_FILES_CHKSUM = "\
8    file://BSD-2-Clause.txt;md5=121c8a0a8fa5961a26b7863034ebcce8 \
9    file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
10    file://COPYING.LESSERv3;md5=6a6a8e020838b23406c81b19c1d46df6 \
11    file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
12    file://COPYINGv3;md5=d32239bcb673463ab874e80d47fae504 \
13    file://LICENSE.Apache-2.0;md5=3b83ef96387f14655fc854ddc3c6bd57 \
14"
15
16SRCREV = "098d985a1b9a15ac828d7b2382297a6955e31e40"
17SRC_URI = "git://github.com/containers/composefs.git;protocol=https;branch=main"
18
19S = "${WORKDIR}/git"
20
21inherit meson
22
23DEPENDS = "openssl"
24
25EXTRA_OEMESON += " \
26    -Dman=disabled \
27    -Dfuse=disabled \
28"
29
30BBCLASSEXTEND = "native"
31