1# Copyright (C) 2022 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Library to parse raw trace event formats	"
5HOMEPAGE = "https://git.kernel.org/pub/scm/libs/libtrace/libtraceevent.git/"
6LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
7LIC_FILES_CHKSUM = "file://LICENSES/GPL-2.0;md5=e6a75371ba4d16749254a51215d13f97 \
8                    file://LICENSES/LGPL-2.1;md5=b370887980db5dd40659b50909238dbd"
9SECTION = "libs"
10DEPENDS = "libtraceevent bison-native flex-native"
11
12SRCREV = "67f3b2ab9f836e6c9c70c94db7aac3251119a263"
13SRC_URI = "git://git.kernel.org/pub/scm/libs/libtrace/libtracefs.git;branch=${BPN};protocol=https \
14           file://0001-makefile-Do-not-preserve-ownership-in-cp-command.patch \
15           "
16S = "${WORKDIR}/git"
17
18inherit pkgconfig
19
20do_install() {
21    oe_runmake install DESTDIR=${D} pkgconfig_dir=${libdir}/pkgconfig
22}
23