1SUMMARY = "An abstraction layer for touchscreen panel events"
2DESCRIPTION = "Tslib is an abstraction layer for touchscreen panel \
3events, as well as a filter stack for the manipulation of those events. \
4Tslib is generally used on embedded devices to provide a common user \
5space interface to touchscreen functionality."
6HOMEPAGE = "http://tslib.org/"
7
8SECTION = "base"
9LICENSE = "LGPL-2.0-or-later & GPL-2.0-or-later"
10LIC_FILES_CHKSUM = "\
11    file://COPYING;md5=fc178bcd425090939a8b634d1d6a9594 \
12    file://tests/COPYING;md5=a23a74b3f4caf9616230789d94217acb \
13"
14
15SRC_URI = "https://github.com/kergoth/tslib/releases/download/${PV}/tslib-${PV}.tar.xz;downloadfilename=tslib-${PV}.tar.xz \
16           file://ts.conf \
17           file://tslib.sh \
18           "
19SRC_URI[sha256sum] = "9b489a54d48006201f2fe955a88c3f857535ac93b6cf8e5a16c7b166c8991dac"
20
21UPSTREAM_CHECK_URI = "https://github.com/kergoth/tslib/releases"
22
23inherit autotools pkgconfig
24
25PACKAGECONFIG ??= "debounce dejitter evthres iir linear median pthres skip lowpass invert variance input touchkit waveshare"
26PACKAGECONFIG[debounce] = "--enable-debounce,--disable-debounce"
27PACKAGECONFIG[dejitter] = "--enable-dejitter,--disable-dejitter"
28PACKAGECONFIG[evthres] = "--enable-evthres,--disable-evthres"
29PACKAGECONFIG[iir] = "--enable-iir,--disable-iir"
30PACKAGECONFIG[linear] = "--enable-linear,--disable-linear"
31PACKAGECONFIG[median] = "--enable-median,--disable-median"
32PACKAGECONFIG[pthres] = "--enable-pthres,--disable-pthres"
33PACKAGECONFIG[skip] = "--enable-skip,--disable-skip"
34PACKAGECONFIG[lowpass] = "--enable-lowpass,--disable-lowpass"
35PACKAGECONFIG[invert] = "--enable-invert,--disable-invert"
36PACKAGECONFIG[variance] = "--enable-variance,--disable-variance"
37PACKAGECONFIG[input] = "--enable-input,--disable-input"
38PACKAGECONFIG[tatung] = "--enable-tatung,--disable-tatung"
39PACKAGECONFIG[touchkit] = "--enable-touchkit,--disable-touchkit"
40PACKAGECONFIG[waveshare] = "--enable-waveshare,--disable-waveshare"
41PACKAGECONFIG[ucb1x00] = "--enable-ucb1x00,--disable-ucb1x00"
42PACKAGECONFIG[mk712] = "--enable-mk712,--disable-mk712"
43PACKAGECONFIG[h3600] = "--enable-h3600,--disable-h3600"
44PACKAGECONFIG[dmc] = "--enable-dmc,--disable-dmc"
45PACKAGECONFIG[linear-h2200] = "--enable-linear-h2200,--disable-linear-h2200"
46PACKAGECONFIG[corgi] = "--enable-corgi,--disable-corgi"
47PACKAGECONFIG[collie] = "--enable-collie,--disable-collie"
48PACKAGECONFIG[arctic2] = "--enable-arctic2,--disable-arctic2"
49PACKAGECONFIG[dmc_dus3000] = "--enable-dmc_dus3000,--disable-dmc_dus3000"
50PACKAGECONFIG[cy8mrln-palmpre] = "--enable-cy8mrln-palmpre,--disable-cy8mrln-palmpre"
51PACKAGECONFIG[galax] = "--enable-galax,--disable-galax"
52PACKAGECONFIG[one-wire-ts-input] = "--enable-one-wire-ts-input,--disable-one-wire-ts-input"
53PACKAGECONFIG[debug] = "--enable-debug,--disable-debug"
54
55do_install:prepend() {
56    install -m 0644 ${UNPACKDIR}/ts.conf ${S}/etc/ts.conf
57}
58
59do_install:append() {
60    install -d ${D}${sysconfdir}/profile.d/
61    install -m 0755 ${UNPACKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
62}
63
64RPROVIDES:tslib-conf = "libts-0.0-conf"
65
66PACKAGES =+ "tslib-conf tslib-tests tslib-calibrate tslib-uinput"
67DEBIAN_NOAUTONAME:tslib-conf = "1"
68DEBIAN_NOAUTONAME:tslib-tests = "1"
69DEBIAN_NOAUTONAME:tslib-calibrate = "1"
70DEBIAN_NOAUTONAME:tslib-uinput = "1"
71
72RDEPENDS:${PN} = "tslib-conf"
73RRECOMMENDS:${PN} = "pointercal"
74
75FILES:${PN}-dev += "${libdir}/ts/*.la"
76FILES:tslib-conf = "${sysconfdir}/ts.conf ${sysconfdir}/profile.d/tslib.sh ${datadir}/tslib"
77FILES:${PN} = "${libdir}/*.so.* ${libdir}/ts/*.so*"
78FILES:tslib-calibrate += "${bindir}/ts_calibrate"
79FILES:tslib-uinput += "${bindir}/ts_uinput"
80
81FILES:tslib-tests = "${bindir}/ts_harvest ${bindir}/ts_print ${bindir}/ts_print_raw ${bindir}/ts_print_mt \
82                     ${bindir}/ts_test ${bindir}/ts_test_mt ${bindir}/ts_verify ${bindir}/ts_finddev ${bindir}/ts_conf"
83
84BBCLASSEXTEND = "native nativesdk"
85