1SUMMARY = "RenderDoc recipe providing renderdoccmd"
2DESCRIPTION = "RenderDoc is a frame-capture based graphics debugger"
3HOMEPAGE = "https://github.com/baldurk/renderdoc"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=36d34a46cb71546195d2b0c626a52e5d"
6
7SRCREV = "35b13a8e8fd2a331854dba6da81a20452e142d6f"
8SRC_URI = " \
9    git://github.com/baldurk/${BPN}.git;protocol=https;branch=v1.x \
10"
11S = "${WORKDIR}/git"
12
13DEPENDS += "virtual/libx11 virtual/libgl libxcb xcb-util-keysyms vim-native"
14
15RDEPENDS:${PN} = "libxcb xcb-util-keysyms"
16
17inherit cmake pkgconfig python3native features_check
18
19REQUIRED_DISTRO_FEATURES = "x11 opengl"
20
21python __anonymous () {
22    # only works on glibc systems
23    if d.getVar('TCLIBC') != "glibc":
24        raise bb.parse.SkipRecipe("incompatible with %s C library" % d.getVar('TCLIBC'))
25}
26
27COMPATIBLE_HOST = "(x86_64|i.86|arm|aarch64).*-linux"
28
29EXTRA_OECMAKE += "\
30    -DENABLE_QRENDERDOC=OFF \
31    -DENABLE_PYRENDERDOC=OFF \
32    -DENABLE_RENDERDOCCMD=ON \
33    -DCMAKE_BUILD_TYPE=Release \
34    -DHOST_NATIVE_CPP_COMPILER="${BUILD_CXX}" \
35"
36
37FILES:${PN} += "${libdir}"
38FILES:${PN}-dev = "${includedir}"
39