1SUMMARY = "Linux CAN network development utilities"
2LICENSE = "GPL-2.0-only & BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://include/linux/can.h;endline=44;md5=a9e1169c6c9a114a61329e99f86fdd31"
4
5DEPENDS = "libsocketcan"
6
7SRC_URI = "git://github.com/linux-can/${BPN}.git;protocol=https;branch=master"
8
9SRCREV = "cfe41963f3425e9adb01a70cfaddedf5e5982720"
10
11S = "${WORKDIR}/git"
12
13inherit autotools pkgconfig update-alternatives
14
15PACKAGES =+ "${PN}-access ${PN}-isotp ${PN}-j1939 ${PN}-cantest ${PN}-slcan ${PN}-log"
16
17FILES:${PN}-access = " \
18    ${bindir}/cangw \
19    ${bindir}/canlogserver \
20    ${bindir}/bcmserver \
21    ${bindir}/socketcand \
22    ${bindir}/cannelloni \
23"
24
25FILES:${PN}-isotp = "${bindir}/isotp*"
26
27FILES:${PN}-j1939 = " \
28    ${bindir}/j* \
29    ${bindir}/testj1939 \
30"
31
32FILES:${PN}-cantest = " \
33    ${bindir}/canbusload \
34    ${bindir}/can-calc-bit-timing \
35    ${bindir}/canfdtest \
36"
37
38FILES:${PN}-slcan = "${bindir}/slcan*"
39
40FILES:${PN}-log = "${bindir}/*log*"
41
42ALTERNATIVE:${PN} = "candump cansend cansequence"
43ALTERNATIVE_LINK_NAME[candump] = "${bindir}/candump"
44ALTERNATIVE_LINK_NAME[cansend] = "${bindir}/cansend"
45ALTERNATIVE_LINK_NAME[cansequence] = "${bindir}/cansequence"
46
47# busybox ip fails to configure can interfaces, so we need iproute2 to do so.
48# See details in http://www.armadeus.com/wiki/index.php?title=CAN_bus_Linux_driver.
49RRECOMMENDS:${PN} += "iproute2"
50
51