15082cc7fSAndrew GeisslerSUMMARY = "Simple, REST-API compliant daemon for automated testing"
25082cc7fSAndrew GeisslerDESCRIPTION = " This is a simple, REST-API compliant daemon which makes \
35082cc7fSAndrew Geisslerautomated testing on hardware possible by removing the need for physical \
45082cc7fSAndrew Geisslerintervention as Q.A.D allows inputs to be injected via http/https requests. \
55082cc7fSAndrew GeisslerThis both eliminates the need to physically interact with the rig and allows \
65082cc7fSAndrew Geisslerfor tasks to be carried out entirely automatically."
75082cc7fSAndrew Geissler
85082cc7fSAndrew GeisslerLICENSE = "MIT & GPL-2.0-or-later"
95082cc7fSAndrew GeisslerLIC_FILES_CHKSUM = "file://LICENSE;md5=402cce7fbcb6ea9ab5a0378dd7f40806 \
105082cc7fSAndrew Geissler                    file://openqa/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
115082cc7fSAndrew Geissler                   "
125082cc7fSAndrew GeisslerSRC_URI = "git://gitlab.com/CodethinkLabs/qad/qad;branch=main;protocol=https \
135082cc7fSAndrew Geissler           file://0001-Fix-warnings-found-by-clang-compiler.patch"
145082cc7fSAndrew Geissler
155082cc7fSAndrew GeisslerSRCREV = "ae0c099c1fdc0ca6f5d631cea6b302937122b362"
165082cc7fSAndrew Geissler
175082cc7fSAndrew GeisslerS = "${WORKDIR}/git"
18*73bd93f1SPatrick WilliamsPV = "0.0+git"
195082cc7fSAndrew Geissler
205082cc7fSAndrew GeisslerDEPENDS = "cjson libmicrohttpd libdrm libpng"
215082cc7fSAndrew Geissler
225082cc7fSAndrew GeisslerFILES:${PN} += "qad"
235082cc7fSAndrew Geisslerinherit meson pkgconfig
245082cc7fSAndrew Geissler
255082cc7fSAndrew Geisslerdo_install () {
265082cc7fSAndrew Geissler    install -d ${D}${bindir}
275082cc7fSAndrew Geissler    install -p -m 755 qad ${D}${bindir}/
285082cc7fSAndrew Geissler}
29