1SUMMARY = "Simple, REST-API compliant daemon for automated testing"
2DESCRIPTION = " This is a simple, REST-API compliant daemon which makes \
3automated testing on hardware possible by removing the need for physical \
4intervention as Q.A.D allows inputs to be injected via http/https requests. \
5This both eliminates the need to physically interact with the rig and allows \
6for tasks to be carried out entirely automatically."
7
8LICENSE = "MIT & GPL-2.0-or-later"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=402cce7fbcb6ea9ab5a0378dd7f40806 \
10                    file://openqa/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
11                   "
12SRC_URI = "git://gitlab.com/CodethinkLabs/qad/qad;branch=main;protocol=https \
13           file://0001-Fix-warnings-found-by-clang-compiler.patch"
14
15SRCREV = "ae0c099c1fdc0ca6f5d631cea6b302937122b362"
16
17S = "${WORKDIR}/git"
18PV = "0.0+git"
19
20DEPENDS = "cjson libmicrohttpd libdrm libpng"
21
22FILES:${PN} += "qad"
23inherit meson pkgconfig
24
25do_install () {
26    install -d ${D}${bindir}
27    install -p -m 755 qad ${D}${bindir}/
28}
29