1SUMMARY = "Liblognorm is a fast-samples based normalization library."
2DESCRIPTION = "Briefly described, liblognorm is a tool to normalize log data."
3HOMEPAGE = "http://www.liblognorm.com"
4SECTION = "base"
5
6LICENSE = "LGPL-2.1-or-later"
7LIC_FILES_CHKSUM = "file://COPYING;md5=ca016db57e008528dace002188c73dad"
8
9DEPENDS = "libfastjson libestr"
10
11SRC_URI = "git://github.com/rsyslog/liblognorm;branch=master;protocol=https \
12           file://0001-Add-asprintf-to-autoconf-function-check-macro.patch \
13           "
14SRCREV = "46c6ee4c8e5f827893e485a4ef1aff04ea881273"
15
16S = "${WORKDIR}/git"
17
18inherit autotools pkgconfig
19
20PACKAGECONFIG ??= "testbench tools"
21PACKAGECONFIG[regexp] = "--enable-regexp,--disable-regexp,pcre2,"
22PACKAGECONFIG[debug] = "--enable-debug,--disable-debug,,"
23PACKAGECONFIG[advstats] = "--enable-advanced-stats,--disable-advanced-stats,,"
24PACKAGECONFIG[docs] = "--enable-docs,--disable-docs,sphinx,"
25PACKAGECONFIG[testbench] = "--enable-testbench,--disable-testbench,,"
26PACKAGECONFIG[valgrind] = "--enable-valgrind,--disable-valgrind,,"
27PACKAGECONFIG[tools] = "--enable-tools,--disable-tools,,"
28