1SUMMARY = "A fast JSON parser/generator for C++ with both SAX/DOM style API"
2HOMEPAGE = "http://rapidjson.org/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://license.txt;md5=ba04aa8f65de1396a7e59d1d746c2125"
6
7SRC_URI = "git://github.com/miloyip/rapidjson.git;nobranch=1"
8
9SRCREV = "0ccdbf364c577803e2a751f5aededce935314313"
10
11PV = "1.1.0+git${SRCPV}"
12
13S = "${WORKDIR}/git"
14
15inherit cmake
16
17EXTRA_OECMAKE += "-DRAPIDJSON_BUILD_DOC=OFF -DRAPIDJSON_BUILD_TESTS=OFF -DRAPIDJSON_BUILD_EXAMPLES=OFF"
18
19# RapidJSON is a header-only C++ library, so the main package will be empty.
20
21ALLOW_EMPTY_${PN} = "1"
22
23BBCLASSEXTEND = "native nativesdk"
24