1SUMMARY = "A fast JSON parser/generator for C++ with both SAX/DOM style API"
2HOMEPAGE = "http://rapidjson.org/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://license.txt;md5=ba04aa8f65de1396a7e59d1d746c2125"
6
7SRC_URI = "git://github.com/miloyip/rapidjson.git;branch=master;protocol=https"
8
9SRCREV = "0ccdbf364c577803e2a751f5aededce935314313"
10
11PV = "1.1.0+git"
12
13S = "${WORKDIR}/git"
14
15inherit cmake
16
17EXTRA_OECMAKE += "-DRAPIDJSON_BUILD_DOC=OFF -DRAPIDJSON_BUILD_TESTS=OFF -DRAPIDJSON_BUILD_EXAMPLES=OFF"
18# the install path for cmake modules etc. is hardcoded as ${prefix}/lib in
19# CMakeLists.txt, which breaks the package split with multilib
20EXTRA_OECMAKE += "-DLIB_INSTALL_DIR=${libdir}"
21
22# RapidJSON is a header-only C++ library, so the main package will be empty.
23
24ALLOW_EMPTY:${PN} = "1"
25
26BBCLASSEXTEND = "native nativesdk"
27