1SUMMARY = "MessagePack implementation for C and C++"
2DESCRIPTION = "MessagePack is an efficient binary serialization format. It's like JSON. but fast and small"
3HOMEPAGE = "http://msgpack.org/index.html"
4LICENSE = "BSL-1.0"
5LIC_FILES_CHKSUM = "file://NOTICE;md5=7a858c074723608e08614061dc044352 \
6                    file://COPYING;md5=0639c4209b6f2abf1437c813b208f2d3 \
7                    file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c \
8                   "
9
10SRC_URI = "https://github.com/msgpack/msgpack-c/releases/download/cpp-${PV}/msgpack-cxx-${PV}.tar.gz"
11SRC_URI[sha256sum] = "23ede7e93c8efee343ad8c6514c28f3708207e5106af3b3e4969b3a9ed7039e7"
12
13S = "${WORKDIR}/msgpack-cxx-${PV}"
14
15DEPENDS += "boost"
16
17inherit cmake pkgconfig
18
19RDEPENDS:${PN}-dev = ""
20
21BBCLASSEXTEND += "native nativesdk"
22