1DESCRIPTION = "A small tool to provide detailed information on the hardware \
2configuration of the machine. It can report exact memory configuration, \
3firmware version, mainboard configuration, CPU version and speed, cache \
4configuration, bus speed, etc. on DMI-capable or EFI systems."
5SUMMARY = "Hardware lister"
6HOMEPAGE = "http://ezix.org/project/wiki/HardwareLiSter"
7SECTION = "console/tools"
8
9LICENSE = "GPL-2.0-or-later"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64|riscv64).*-linux"
13
14PV .= "+git"
15SRCREV = "4c6497c8b0a67cd9fa9693e9101a7cafd3297e81"
16SRC_URI = " \
17    git://github.com/lyonel/lshw.git;protocol=https;branch=master \
18    file://0001-disable-docbook2man.patch \
19"
20
21S = "${WORKDIR}/git"
22
23inherit pkgconfig
24
25DEPENDS = "gettext-native"
26
27PACKAGECONFIG ??= "zlib"
28PACKAGECONFIG[sqlite] = "SQLITE=1,SQLITE=0,sqlite3"
29PACKAGECONFIG[zlib]   = "ZLIB=1,ZLIB=0,zlib gzip-native"
30
31# use the PACKAGECONFIG configurations arguments
32EXTRA_OEMAKE = "${PACKAGECONFIG_CONFARGS} RPM_OPT_FLAGS='${CFLAGS}'"
33
34do_compile() {
35    # build core only - don't ship gui
36    oe_runmake -C src core
37}
38
39do_install() {
40    oe_runmake install DESTDIR=${D}
41}
42
43BBCLASSEXTEND = "native"
44