1SUMMARY = "Expression parser"
2HOMEPAGE = "https://github.com/ArashPartow/exprtk"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
6SRCREV = "f46bffcd6966d38a09023fb37ba9335214c9b959"
7
8SRC_URI = "git://github.com/ArashPartow/exprtk.git;branch=release;protocol=https"
9
10S = "${WORKDIR}/git"
11
12# other packages commonly reference the file directly as "exprtk.hpp"
13# create symlink to allow this usage
14do_install() {
15    install -d ${D}/${includedir}
16    install -m 0644 ${S}/exprtk.hpp ${D}/${includedir}/exprtk.hpp
17}
18
19# exprtk is a header only C++ library, so the main package will be empty.
20RDEPENDS:${PN}-dev = ""
21
22BBCLASSEXTEND = "native nativesdk"
23