1SUMMARY = "Paho MQTT - C++ libraries for the MQTT and MQTT-SN protocols"
2DESCRIPTION = "Client implementation of open and standard messaging protocols for Machine-to-Machine (M2M) and Internet of Things (IoT)."
3HOMEPAGE = "http://www.eclipse.org/paho/"
4SECTION = "console/network"
5LICENSE = "EPL-2.0 | EDL-1.0"
6
7LIC_FILES_CHKSUM = " \
8    file://src/mqtt/message.h;beginline=9;endline=18;md5=c5ceecf5ab99d44dcfaaabdce289071b \
9    file://edl-v10;md5=3adfcc70f5aeb7a44f3f9b495aa1fbf3 \
10    file://epl-v20;md5=d9fc0efef5228704e7f5b37f27192723 \
11"
12
13SRC_URI = "git://github.com/eclipse/paho.mqtt.cpp;protocol=https;branch=v1.3.x \
14           file://0001-cmake-Use-CMAKE_INSTALL_LIBDIR-and-CMAKE_INSTALL_BIN.patch \
15           "
16SRCREV = "5e0d1bf37b4826d680ec066ec42afd133851a681"
17
18DEPENDS = "openssl paho-mqtt-c"
19
20S = "${WORKDIR}/git"
21
22inherit cmake
23
24EXTRA_OECMAKE += "-DPAHO_WITH_SSL=ON"
25