1SUMMARY = "NVMe management command line interface"
2HOMEPAGE = "https://github.com/linux-nvme/nvme-cli"
3SECTION = "console/utils"
4LICENSE = "GPL-2.0-only & CC0-1.0 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=8264535c0c4e9c6c335635c4026a8022 \
6                    file://ccan/licenses/CC0;md5=c17af43b05840255a6fedc5eda9d56cc \
7                    file://ccan/licenses/BSD-MIT;md5=838c366f69b72c5df05c96dff79b35f2"
8DEPENDS = "json-c libnvme"
9SRCREV = "b340fd7dcf1aef76f8d46ab28bef3c170d310887"
10
11SRC_URI = "git://github.com/linux-nvme/nvme-cli.git;branch=master;protocol=https \
12           file://0001-nvme-Use-C99-types-for-uint32_t.patch \
13           file://0001-plugins-ssstc-Replace-__uint16_t-with-uint16_t.patch \
14           "
15
16S = "${WORKDIR}/git"
17
18inherit bash-completion meson pkgconfig systemd
19
20EXTRA_OEMESON += "-Dsystemddir=${systemd_unitdir}/system"
21
22pkg_postinst_ontarget:${PN}-user () {
23    ${sbindir}/nvme gen-hostnqn > ${sysconfdir}/nvme/hostnqn
24    ${bindir}/uuidgen > ${sysconfdir}/nvme/hostid
25}
26
27PACKAGES =+ "${PN}-dracut ${PN}-zsh-completion ${PN}-user"
28
29FILES:${PN} += "${systemd_system_unitdir}"
30FILES:${PN}-dracut = "${nonarch_libdir}/dracut/dracut.conf.d"
31FILES:${PN}-zsh-completion = "${datadir}/zsh/site-functions"
32ALLOW_EMPTY:${PN}-user = "1"
33
34RDEPENDS:${PN}-user = "util-linux-uuidgen"
35
36# This one is reproducible only on 32bit MACHINEs
37# http://errors.yoctoproject.org/Errors/Details/766964/
38# git/plugins/virtium/virtium-nvme.c:205:63: error: passing argument 1 of 'localtime' from incompatible pointer type [-Wincompatible-pointer-types]
39CFLAGS += "-Wno-error=incompatible-pointer-types"
40