1SUMMARY = "NVMe management command line interface"
2HOMEPAGE = "https://github.com/linux-nvme/nvme-cli"
3SECTION = "console/utils"
4LICENSE = "GPL-2.0-only & CC0-1.0 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=8264535c0c4e9c6c335635c4026a8022 \
6                    file://ccan/licenses/CC0;md5=c17af43b05840255a6fedc5eda9d56cc \
7                    file://ccan/licenses/BSD-MIT;md5=838c366f69b72c5df05c96dff79b35f2"
8DEPENDS = "json-c libnvme"
9SRCREV = "43b716b982da3df1cf8c4658f7c31b0fe28d377b"
10
11SRC_URI = "git://github.com/linux-nvme/nvme-cli.git;branch=master;protocol=https"
12
13S = "${WORKDIR}/git"
14
15inherit bash-completion meson pkgconfig systemd
16
17EXTRA_OEMESON += "-Dsystemddir=${systemd_unitdir}/system"
18
19pkg_postinst_ontarget:${PN}() {
20    ${sbindir}/nvme gen-hostnqn > ${sysconfdir}/nvme/hostnqn
21    ${bindir}/uuidgen > ${sysconfdir}/nvme/hostid
22}
23
24PACKAGES =+ "${PN}-dracut ${PN}-zsh-completion"
25
26FILES:${PN} += "${systemd_system_unitdir}"
27FILES:${PN}-dracut = "${nonarch_libdir}/dracut/dracut.conf.d"
28FILES:${PN}-zsh-completion = "${datadir}/zsh/site-functions"
29
30RDEPENDS:${PN} = "util-linux-uuidgen"
31