1SUMMARY = "Tools for performance analysis"
2HOMEPAGE = "http://lmbench.sourceforge.net/"
3SECTION = "console/utils"
4LICENSE = "GPL-2.0-only & GPL-2.0-with-lmbench-restriction"
5LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
6                    file://COPYING-2;md5=8e9aee2ccc75d61d107e43794a25cdf9"
7
8inherit autotools-brokensep update-alternatives
9
10DEPENDS += "libtirpc"
11CFLAGS += "-I${STAGING_INCDIR}/tirpc"
12LDLIBS += " -ltirpc "
13
14PR = "r2"
15
16SRC_URI = "${SOURCEFORGE_MIRROR}/lmbench/lmbench-${PV}.tgz \
17           file://lmbench-run \
18           file://rename-line-binary.patch \
19           file://update-results-script.patch \
20           file://obey-ranlib.patch \
21           file://update-config-script.patch \
22           file://lmbench_result_html_report.patch \
23           file://fix-lmbench-memory-check-failure.patch \
24           file://0001-avoid-gcc-optimize-away-the-loops.patch \
25           file://0001-lat_http.c-Add-printf-format.patch \
26           file://0001-Check-for-musl-define-guard-before-redefining-sockle.patch \
27           file://0002-build-Adjust-CFLAGS-LDFLAGS-to-append-values-passed-.patch \
28           file://0001-src-Makefile-use-libdir-instead-of-hardcoded-lib.patch \
29           file://0001-lmbench-Point-webpage-lm-to-target-directory.patch \
30           file://0001-doc-Fix-typos-in-manual-pages.patch \
31           file://0001-lat_fifo-Fix-cleanup-sequence.patch \
32           file://0001-doc-Fix-typos-in-lat_unix_connect-manual-page.patch \
33           "
34SRC_URI[md5sum] = "b3351a3294db66a72e2864a199d37cbf"
35SRC_URI[sha256sum] = "cbd5777d15f44eab7666dcac418054c3c09df99826961a397d9acf43d8a2a551"
36
37UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/lmbench/files/development/"
38UPSTREAM_CHECK_REGEX = "lmbench-(?P<pver>\d+(\.\d+)+-[a-z]+\d+)"
39
40EXTRA_OEMAKE = 'CC="${CC}" AR="${AR}" RANLIB="${RANLIB}" CFLAGS="${CFLAGS}" \
41                LDFLAGS="${LDFLAGS}" LDLIBS="${LDLIBS}" LD="${LD}" OS="${TARGET_SYS}" \
42                TARGET="${TARGET_OS}" BASE="${prefix}" MANDIR="${mandir}"'
43
44do_configure() {
45    :
46}
47
48do_compile () {
49    for CONFIG_SITE_ITEM in $CONFIG_SITE; do
50        . $CONFIG_SITE_ITEM
51    done
52    if [ X"$ac_cv_uint" = X"yes" ]; then
53        CFLAGS="${CFLAGS} -DHAVE_uint"
54    fi
55    install -d ${S}/bin/${TARGET_SYS}
56    oe_runmake -C src
57}
58
59do_install () {
60    install -d ${D}${sysconfdir}/default/volatiles \
61           ${D}${bindir} ${D}${mandir} \
62           ${D}${datadir}/lmbench/scripts
63
64    echo "d root root 0755 ${localstatedir}/run/${BPN} none" \
65           > ${D}${sysconfdir}/default/volatiles/99_lmbench
66    if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
67        install -d ${D}${sysconfdir}/tmpfiles.d
68        echo "d /run/${BPN} - - - -" \
69              > ${D}${sysconfdir}/tmpfiles.d/lmbench.conf
70    fi
71
72    oe_runmake BASE="${D}${prefix}" MANDIR="${D}${mandir}" \
73            DESTDIR="${D}" \
74            -C src install
75    mv ${D}${bindir}/line ${D}${bindir}/lm_line
76    install -m 0755 ${WORKDIR}/lmbench-run ${D}${bindir}/
77    install -m 0755 ${S}/bin/${TARGET_SYS}/cache ${D}${bindir}/
78    sed -i -e 's,^SHAREDIR=.*$,SHAREDIR=${datadir}/${BPN},;' \
79           -e 's,^CONFIG=.*$,CONFIG=`$SCRIPTSDIR/config`,;' \
80           ${D}${bindir}/lmbench-run
81    install -m 0755 ${S}/scripts/lmbench ${D}${bindir}
82    install -m 0755 ${S}/scripts/* ${D}${datadir}/lmbench/scripts
83    install -m 0644 ${S}/src/webpage-lm.tar ${D}${datadir}/lmbench
84}
85
86pkg_postinst:${PN} () {
87    if [ -z "$D" ]; then
88        if command -v systemd-tmpfiles >/dev/null; then
89            systemd-tmpfiles --create ${sysconfdir}/tmpfiles.d/lmbench.conf
90        elif [ -e ${sysconfdir}/init.d/populate-volatile.sh ]; then
91            ${sysconfdir}/init.d/populate-volatile.sh update
92        fi
93    fi
94}
95
96RDEPENDS:${PN} = "perl"
97FILES:${PN} += "${datadir}/lmbench"
98
99ALTERNATIVE:${PN} = "stream"
100ALTERNATIVE_LINK_NAME[stream] = "${bindir}/stream"
101
102