1SUMMARY = "Tools for performance analysis"
2HOMEPAGE = "http://lmbench.sourceforge.net/"
3SECTION = "console/utils"
4LICENSE = "GPL-2.0-only & GPL-2.0-with-lmbench-restriction"
5LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
6                    file://COPYING-2;md5=8e9aee2ccc75d61d107e43794a25cdf9"
7
8inherit autotools-brokensep update-alternatives
9
10DEPENDS += "libtirpc"
11CFLAGS += "-I${STAGING_INCDIR}/tirpc"
12
13
14SRC_URI = "${SOURCEFORGE_MIRROR}/lmbench/lmbench-${PV}.tgz \
15           file://lmbench-run \
16           file://rename-line-binary.patch \
17           file://update-results-script.patch \
18           file://obey-ranlib.patch \
19           file://update-config-script.patch \
20           file://lmbench_result_html_report.patch \
21           file://fix-lmbench-memory-check-failure.patch \
22           file://0001-avoid-gcc-optimize-away-the-loops.patch \
23           file://0001-lat_http.c-Add-printf-format.patch \
24           file://0002-build-Adjust-CFLAGS-LDFLAGS-to-append-values-passed-.patch \
25           file://0001-src-Makefile-use-libdir-instead-of-hardcoded-lib.patch \
26           file://0001-lmbench-Point-webpage-lm-to-target-directory.patch \
27           file://0001-doc-Fix-typos-in-manual-pages.patch \
28           file://0001-lat_fifo-Fix-cleanup-sequence.patch \
29           file://0001-doc-Fix-typos-in-lat_unix_connect-manual-page.patch \
30           file://0001-bench.h-Fix-typo-in-specifying-string.h.patch \
31           file://0001-scripts-build-Fix-the-tests-to-build-with-clang15.patch \
32           "
33SRC_URI[md5sum] = "b3351a3294db66a72e2864a199d37cbf"
34SRC_URI[sha256sum] = "cbd5777d15f44eab7666dcac418054c3c09df99826961a397d9acf43d8a2a551"
35
36UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/lmbench/files/development/"
37UPSTREAM_CHECK_REGEX = "lmbench-(?P<pver>\d+(\.\d+)+-[a-z]+\d+)"
38
39export OS = "${TARGET_SYS}"
40export TARGET = "${TARGET_OS}"
41
42EXTRA_OEMAKE = 'CC="${CC}" AR="${AR}" RANLIB="${RANLIB}" CFLAGS="${CFLAGS}" \
43                LDFLAGS="${LDFLAGS}" LD="${LD}" OS="${TARGET_SYS}" \
44                TARGET="${TARGET_OS}" BASE="${prefix}" MANDIR="${mandir}"'
45
46do_configure() {
47    :
48}
49
50do_compile () {
51    for CONFIG_SITE_ITEM in $CONFIG_SITE; do
52        . $CONFIG_SITE_ITEM
53    done
54    if [ X"$ac_cv_uint" = X"yes" ]; then
55        CFLAGS="${CFLAGS} -DHAVE_uint"
56    fi
57    install -d ${S}/bin/${TARGET_SYS}
58    ${S}/scripts/build
59}
60
61do_install () {
62    install -d ${D}${sysconfdir}/default/volatiles \
63           ${D}${bindir} ${D}${mandir} \
64           ${D}${datadir}/lmbench/scripts
65
66    echo "d root root 0755 ${localstatedir}/run/${BPN} none" \
67           > ${D}${sysconfdir}/default/volatiles/99_lmbench
68    if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
69        install -d ${D}${sysconfdir}/tmpfiles.d
70        echo "d /run/${BPN} - - - -" \
71              > ${D}${sysconfdir}/tmpfiles.d/lmbench.conf
72    fi
73
74    oe_runmake BASE="${D}${prefix}" MANDIR="${D}${mandir}" \
75            DESTDIR="${D}" \
76            -C src install
77    mv ${D}${bindir}/line ${D}${bindir}/lm_line
78    install -m 0755 ${WORKDIR}/lmbench-run ${D}${bindir}/
79    install -m 0755 ${S}/bin/${TARGET_SYS}/cache ${D}${bindir}/
80    sed -i -e 's,^SHAREDIR=.*$,SHAREDIR=${datadir}/${BPN},;' \
81           -e 's,^CONFIG=.*$,CONFIG=`$SCRIPTSDIR/config`,;' \
82           ${D}${bindir}/lmbench-run
83    install -m 0755 ${S}/scripts/lmbench ${D}${bindir}
84    install -m 0755 ${S}/scripts/* ${D}${datadir}/lmbench/scripts
85    install -m 0644 ${S}/src/webpage-lm.tar ${D}${datadir}/lmbench
86}
87
88pkg_postinst:${PN} () {
89    if [ -z "$D" ]; then
90        if command -v systemd-tmpfiles >/dev/null; then
91            systemd-tmpfiles --create ${sysconfdir}/tmpfiles.d/lmbench.conf
92        elif [ -e ${sysconfdir}/init.d/populate-volatile.sh ]; then
93            ${sysconfdir}/init.d/populate-volatile.sh update
94        fi
95    fi
96}
97
98RDEPENDS:${PN} = "perl"
99FILES:${PN} += "${datadir}/lmbench"
100
101ALTERNATIVE:${PN} = "stream hello"
102ALTERNATIVE_LINK_NAME[stream] = "${bindir}/stream"
103ALTERNATIVE_LINK_NAME[hello] = "${bindir}/hello"
104