1SUMMARY = "Filesystem and Disk Benchmarking Tool"
2HOMEPAGE = "http://www.iozone.org/"
3AUTHOR = "Don Capps <don.capps2@verizon.net>, William D. Norcott <wnorcott@us.oracle.com>"
4SECTION = "console/tests"
5LICENSE = "iozone3"
6LIC_FILES_CHKSUM = "file://iozone.c;beginline=37;endline=48;md5=7331260091868dcad0f9edea735b5f4b \
7    file://iozone.c;beginline=276;endline=282;md5=77f9ee51e45b57a7e7519c4fa0b4f00b \
8"
9SRC_URI = "http://www.iozone.org/src/current/${BPN}_${PV}.tar \
10    file://parallelism.patch \
11    file://0001-let-system-headers-provide-pread64.patch \
12    file://copyright.txt \
13"
14SRC_URI[sha256sum] = "114ce5c071873b9a2c7ba6e73d05d5ef7e66564392acbfcdc0b3261db10fcbe7"
15
16UPSTREAM_CHECK_REGEX = "iozone3_(?P<pver>\d+).tar"
17
18S = "${WORKDIR}/${BPN}_${PV}/src/current"
19
20#
21# All other arches can use the default OEMAKE except those
22# explicitly listed below. Another, the iozone3 Makefile
23# needs to be told about the cross-compiler explicitly here.
24#
25EXTRA_OEMAKE:powerpc = "linux-powerpc CC='${CC}' GCC='${CC}'"
26EXTRA_OEMAKE:powerpc64 = "linux-powerpc64 CC='${CC}' GCC='${CC}'"
27EXTRA_OEMAKE:powerpc64le = "linux-powerpc64 CC='${CC}' GCC='${CC}'"
28EXTRA_OEMAKE:x86-64 = "linux-AMD64 CC='${CC}' GCC='${CC}'"
29EXTRA_OEMAKE:arm = "linux-arm CC='${CC}' GCC='${CC}'"
30EXTRA_OEMAKE = "linux CC='${CC}' GCC='${CC}'"
31
32TARGET_CC_ARCH += "${LDFLAGS}"
33
34do_install() {
35    install -d ${D}${bindir} \
36               ${D}${mandir}/man1 \
37               ${D}${datadir}/doc/${BPN}/examples
38
39    install -m 0755 ${S}/iozone ${D}${bindir}
40    install -m 0755 ${S}/fileop ${D}${bindir}
41    install -m 0644 ${WORKDIR}/${BPN}_${PV}/docs/iozone.1 ${D}${mandir}/man1/
42    install -m 0644 ${WORKDIR}/copyright.txt ${D}${datadir}/doc/${BPN}/
43
44    install -m 0644 ${S}/*.dem ${D}${datadir}/doc/${BPN}/examples
45    install -m 0644 ${S}/client_list ${D}${datadir}/doc/${BPN}/examples
46    install -m 0644 ${S}/Gnuplot.txt ${D}${datadir}/doc/${BPN}/examples
47
48    install -m 0755 ${S}/Generate_Graphs ${D}${datadir}/doc/${BPN}/examples
49    install -m 0755 ${S}/gengnuplot.sh ${D}${datadir}/doc/${BPN}/examples
50    install -m 0755 ${S}/report.pl ${D}${datadir}/doc/${BPN}/examples
51
52    install -m 0644 ${WORKDIR}/${BPN}_${PV}/docs/Iozone_ps.gz ${D}${datadir}/doc/${BPN}/
53    install -m 0644 ${WORKDIR}/${BPN}_${PV}/docs/IOzone_msword_98.pdf ${D}${datadir}/doc/${BPN}/
54    install -m 0644 ${WORKDIR}/${BPN}_${PV}/docs/Run_rules.doc ${D}${datadir}/doc/${BPN}/
55}
56
57FILES:${PN} += "${datadir}/doc/${PN}/copyright.txt"
58
59# LICENSE:
60#
61#  Copyright 1991, 1992, 1994, 1998, 1999, 2002   William D. Norcott
62#
63#  License to freely use and distribute this software is hereby granted
64#  by the author, subject to the condition that this copyright notice
65#  remains intact.  The author retains the exclusive right to publish
66#  derivative works based on this work, including, but not limited to
67#  revised versions of this work.
68#
69
70#
71# Below is author reply to question about distributing iozone3 in
72# OpenEmbedded:
73#
74# ========================================================================
75#
76# Marcin,
77#
78#     Re-distribution is permitted as long as the copyright is
79#     maintained and the source code is not changed. I do not
80#     see a problem with your mods to enable fileop for Linux-arm,
81#     as these mods have been returned to the Iozone folks,
82#     and they have been accepted for inclusion in the next
83#     release :-)
84#
85# Thank you for your contribution,
86# Don Capps
87#
88# ----- Original Message -----
89# From: "Marcin Juszkiewicz" <firma@hrw.one.pl>
90# To: "Don Capps" <don.capps2@verizon.net>; "William D. Norcott"
91# <wnorcott@us.oracle.com>
92# Sent: Sunday, October 29, 2006 4:55 PM
93# Subject: iozone3 263 patch for arm and License question
94#
95#
96# > Morning
97# >
98# > I want to include iozone3 in OpenEmbedded [1] metadata to give it for
99# > other developers. Currently OE is used to build few distributions for
100# > misc platforms: ARM, SH3, SH4, x86, PowerPC and different types of
101# > machines (PDA, settopbox, devboards, desktops, thin clients, routers).
102# >
103# > According to your distribution of derivations is forbidden. Packaging
104# > iozone3 in OpenEmbedded will not involve any source code changes. But
105# > when I was building it for ARM I discovered that fileop binary was not
106# > built - so I created patch for it (attached). Not yet tested it on target
107# > device.
108# >
109# > Thus, I seek your written permission via e-mail to distribute a package of
110# > the unmodified source code and also a package of the pre-compiled binary.
111# > Your copyright statement will be included in the package.
112# >
113# >
114# > 1. http://www.openembedded.org/
115# >
116# > Regards
117# > --
118# > JID: hrw-jabber.org
119# > OpenEmbedded developer/consultant
120
121